Uh oh, something's not right

Roon Core Machine

Intel NUC running ROCK

Networking Gear & Setup Details

Home Hub 2000 Router —>Linksys Velop MESH system in bridge mode

Connected Audio Devices

HiFiBerry Digi+ attached via Ethernet cable to Linksys VELOP Pod which is attached by Ethernet cable to router

HiFiBerry DAC+ attached via Ethernet cable to another Linksys VELOP pod which is connected via Wfi to above Linksys pod

I also sometimes listen on my Dell XPS 15 laptop, Samsung A50 phone, or Amazon Fire tablet, which usually serve as controllers.

Number of Tracks in Library

55411 tracks

Description of Issue

System was working fine until about a week ago, when we had an internet outage that required the service provider to perform some repairs to our cable box outside the house.

Since then, Roon has not been working. A song will play for 10-30 seconds, then you get the circling “Waiting to connect to Core” pop up, followed by the “Uh oh” pop up. Sometimes it might play for a few minutes before conking out, but no more than that.

Sometimes the Core cannot be found at all on opening the browser, or takes a very long time to connect.

The DAC+ also periodically disappears from the system,

Rebooting the Core and the router has not helped.

What to do next?

If ROCK wasn’t brought down gracefully before the power to the cable was cut, then the Roon library might be corrupted.

Do you have a Settings==>Backup from before that outage?

“Outage” is probably not the correct word. The TV and internet connection were just cutting out intermittently.

I can also access my entire library for the times when the system is running, even if only for a matter of seconds. So I don’t know if that is the problem.

Ok, but it sounds like a corrupted library, no matter what may have caused it.

Tagging @support.

1 Like

Hi @Faizal_Ali,

I am sorry you’re having issues! I wanted to find out why so I enabled diagnostics mode on your account and here’s what I’ve found:

09/14 14:06:22 Trace: [raat] [HiFiBerry Digi+ @] => ConnectionFailed
09/14 14:06:22 Trace: [raat] [HiFiBerry Digi+ @] client connection failed. Retrying in 500ms
09/14 14:06:23 Trace: [raat] [HiFiBerry Digi+ @] connecting (attempt 2)
09/14 14:06:23 Trace: [raat] [HiFiBerry Digi+ @] => Connecting

There are 1329 instances of this error in one of your 21 logs alone and it seems to be happening once a minute. Every once in a while it connects but then it’s back to the above error. Whatever the case, it’s filling up the logging with networking errors.

I would double check your connection to your DAC first. Make sure it’s got a solid 5ghz connection if using wifi and regardless of how it’s connected, power it down for 30 seconds and try to use it again.

Please let me know!

1 Like

Thanks! I’ll try that when I get home tonight.

1 Like

OK, the problem is at least partially solved. While rebooting the Digi+ did not help, I went to its UI and disabled the Wifi connection. The device is connected via ethernet and it was possibly trying to connect via WiFi but didn’t have the password, hence the many failed connection attempts. Anyway, whether or not that was the problem, I can now connect to the Core and most devices seem to be working for now.

However, the problem of the disappearing DAC remains. This is the HifiBerry DAC+. It keeps reappearing then disappearing from the list of audio zones on Roon, even though it is visible on the UI for my router. I also can’t seem to access its UI. I just get a “This site cannot be reached” screen when I enter its IP address. So all I could think of trying is unplugging/replugging its power supply, but that hasn’t helped.

I realize this may be more of a HifiBerry problem than a Roon problem, but any suggestions would be appreciated.

EDIT: Just realized it is an older HifiBerry which may not have the web UI and may need to be configured by SSH. No clue where to start with that…

Hi @Faizal_Ali,

Thank you for your update. I decided to check diagnostics again and we’re seeing more of the same.

09/15 19:41:13 Trace: [raatserver] [RaatServer raspberrypi-kitchen @] lost client connection. Retrying
09/15 19:41:13 Trace: [raatserver] [RaatServer raspberrypi-kitchen @] connecting (attempt 1)
09/15 19:41:13 Info: [transport] destroyed zone Kitchen was playing? False
09/15 19:41:13 Trace: [zone Kitchen] Suspend
09/15 19:41:13 Info: [zone Kitchen] Canceling Pending Sleep
09/15 19:41:13 Info: [zone Kitchen] Canceling Pending Sleep
09/15 19:41:15 Info: [stats] 23536mb Virtual, 2150mb Physical, 1392mb Managed, 310 Handles, 94 Threads
09/15 19:41:20 Trace: [storage] [directory] initial scan of /roon/sys/storage/smbmounts/RoonStorage_831725571d74fa36b43932e920090c14a13b7114 took: 22993 ms
09/15 19:41:23 Trace: [raatserver] [RaatServer raspberrypi-kitchen @] client connection failed. Retrying in 500ms

Since this is a wired connection there’s only a few possibilities. Bad port, bad cable, or bad unit. I know it doesn’t make much sense given that the perceived catalyst was an interruption of ISP services. The logging shows exactly what you describe though. In this most recent attempt on your part, there are 121 failed reconnections with approximately the same number of success messages. Here’s the success just a few minutes after the failure:

09/15 19:49:24 Trace: [raatserver] [RaatServer raspberrypi-kitchen @] connecting (attempt 2)
09/15 19:49:26 Trace: [Main System] [Enhanced, 16/44 FLAC => 32/44] [100% buf] [PLAYING @ 4:14/13:30] Symphony No. 5 in B flat, WAB 105: Scherzo: Molto vivace (Schnell), Trio: Im gleichen Tempo - Giuseppe Sinopoli / Staatskapelle Dresden / Anton Bruckner
09/15 19:49:28 Trace: [raatserver] [RaatServer raspberrypi-kitchen @] connected

Try checking those cables and if the rasp is connected to a switch, try connecting directly to the router with a different cable if at all possible. We just need to go down the line and find the problem child.


You’ll notice, though, that those involve two different devices.

The path “HiFiBerry Digi+” in comment #4 goes like this:

Digi+ → ethernet cable → MESH pod #1 → ethernet cable → router.

For “raspberrypi-kitchen” in comment #8:

DAC+ → ethernet cable → MESH pod #2 → Wifi connection → MESH pod #1 → router.

So to my, perhaps naive, thinking this seems to indicate the problem lies with one of the elements in common in the two pathways. i.e. MESH pod #1 or the router.

I should say that, over the time this problem has existed, my network has generally not been performing optimally. Slow download times, intermittent drop outs, etc. And it often seems to me that Roon, being a rather complex system, serves as a “canary in the coal mine” re: the health of the network.

So should I consider that the problem probably lies with the MESH system and/or router rather than somewhere further downstream and try address that? Or am I just not understanding this stuff?

I really like your canary in the coal mine comparison. It’s perfect. You are absolutely right that Roon needs some serious intranet bandwidth to deliver the high-res audio.

As far as your last paragraph goes, I am inclined to think it’s network conditions causing this. The only way to know for sure is to connect your setup directly to the router and bypass the mesh pods altogether. If the problem goes away, you have your culprit.


I called Linksys and they had me shut down the Mesh system and reboot it as if it was a new installation. Fingers crossed, but so far that seems to have solved the problem.


That’s amazing and I’m happy for you!

Let us know if the issue comes back or if there’s anything else we can do to help.


1 Like

FTR and for the benefit of other Linksys Mesh users (Velop in my case) if your network devices or any attached devices are “misbehaving” i.e. do bizarre or unpredictable things just restart the mesh devices and 99% of the time that will resolve the problem.
I spent many hours chasing “ghosts” on my network which were usually resolved with a mesh restart, I got fed up with the Velop mesh and sold them at a considerable loss.

1 Like

I thought I had done that by just pushing the red button on the bottom of the nodes, but there was a bit more I had to do for a full re-start.

Roon doesn’t work for me without a mesh system. The wifi on its own does not cut it. Never really had any problems with the Velop system before now.

As you’ve no doubt discovered the “red buttons” can perform many functions depending on the number presses. I spent a few days, many hours at a time, dealing with a very co-operative but unproductive support team and eventually gave up.

I’ve had better luck with their support team, but they do seem to go slowly thru an algorithm. The time I called before this, it seemed to me the woman helping me was new to the job, and that was likely confirmed when, after finally solving the issue, I could hear her colleagues cheering in the background.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.