UI errors out when executed

Core Machine (Operating system/System info/Roon build number)
Lenovo ThinkCentre V530s SFF Intel Octa-Core (8 Cores) i7-9700, 32GB RAM, 1TB SSD, WiFi Intel-AC 3165, W10P Business Desktop

using 2 65 inch monitors running at 4096 x 2160 with a font size of 175%.

Display Adapters
Intel UHD Graphics 630
NVIDIA GeForce GT 1030

Windows 10 Pro

Roon Version 1.8 (I think. It’s the most current version. The program won’t launch so I am unable to get the build number.
Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet. Netgear

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Devialet 800. Ethernet

Description Of Issue

I am receiving the following error :

This is the exact same issue that I had in October 2019. It was resolved by installing the most current graphic drivers. In this case, the most current drivers are installed.

.net Runtime Error
Application: Roon.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.AccessViolationException
at Broo.Gdi.ChoosePixelFormat(IntPtr, PIXELFORMATDESCRIPTOR ByRef)
at Broo.Engine.WglLoaderWindow.LoadWgl(PIXELFORMATDESCRIPTOR ByRef, System.String ByRef, System.String ByRef)
at Broo.Engine.GlWindow.InitializeContexts()
at Broo.Engine.GlWindow…ctor(Broo.Engine.OpenGlWindow)
at Broo.Engine.OpenGlWindow…ctor()
at Broo.Engine.DeviceTarget…ctor(Broo.Engine.Window ByRef)
at Broo.BrooLoader.Load(Boolean, System.String, System.String, System.String, Broo.Engine.Engine ByRef, Broo.Engine.Window ByRef, Broo.Engine.LoadContext ByRef, System.String ByRef)
at Sooloos.Application.Main(System.String[])

Application Error
Faulting application name: Roon.exe, version: 1.0.0.0, time stamp: 0x6036a2de
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x0000000000000000
Faulting process id: 0x24f8
Faulting application start time: 0x01d7160f209a9542
Faulting application path: C:\Users\jwgie\AppData\Local\Roon\Application\Roon.exe
Faulting module path: unknown
Report Id: 25a9da87-696b-43d8-b863-8f082e663e0a
Faulting package full name:
Faulting package-relative application ID:

Please disregard. I have fixed the problem. I connected both monitors to the NVDIA graphics card. Now Roon boots without a hitch.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.