UN 7300 Series LG TV not recognised as Airplay Endpoint


I have a 55UN7300PTC LG TV which supports airplay but it doesn’t show up as an endpoint in ROON. All my other (Apple) Airplay endpoints do while the TV is also recognised as Airplay address by all my other devices.

Anybody has any idea. I have a DAC/AMP connected via the TOSLINK out of the TV and I would like to use this as an endpoint.

Hey @Aernoud_Dekker,

Thanks a lot for sharing how you’d like to use Roon — we’re very sorry we didn’t have a chance to see and reply to this thread until today.

I was wondering, what device are you using as a Roon Core? Outside of Roon, can you connect that device to your TV? Is the TV exposed on the same network that your Roon Core is on?


Yes, very surprised that response took so long.

I’m using a M1 Apple Mini. All is connected to the same network yes.


No Support / Answers?

Hi Aernoud,

I have the same issue with my LG G1 OLED TV. It doesn’t show in the Audio settings on ROON, but is recognised by my other devices.

Hey @Aernoud_Dekker and @Barry_Andrews :wave:

I’m sorry we never said anything after our initial response. I’ve taken this question to our team and I have some clarification I can share:

The TVs you’ve mentioned (55UN7300PTC LG TV and LG G1 OLED TV) alongside many other TVs support AirPlay connections via AirPlay 2. Unfortunately, at this time, AirPlay 2 is not supported in Roon, hence, the TVs don’t show up as an AirPlay zone in Roon.

As a workaround, you can play music to your TV when you connect it to your Mac computer/ iPhone / iPad and play to System Output.


Thanks for coming back on this.

Airplay 2? Who could have thought. I cannot remember LG mentions this in their documentation.

Be aware that you can connect these TV’s to external amplifiers/speakers using optical or HDMI, so they make interesting endpoints.

I assume you guys work on supporting Airplay 2, so this issue might solve itself in the future.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.