Unable to access fileshare on Nucleus+ via macOS 10.14.3


(Tor Gunnar Berland) #1

I get an error when trying to connect to the Nucleus via finder in macOS. Works fine via Windows. So any hint of what is wrong here ?


(Mike) #2

Any hint what the error is?


(Tor Gunnar Berland) #3

It states connecting for a long time (5 seconds); then conclude with Connection failed.
On windows (even from same computer; both bootcamp and parallels) it is connecting at once and everything just works.


(Geoff Coupe) #4

Tor, I’ve moved your post over to the Support/Nucleus Support category, where it will be seen by the support team…


(Tor Gunnar Berland) #5

I’m sure it is somehow connected to macOS, it worked a few months back. Not sure what happened.

Maybe Apple went “Pentagon-style” again ?


(Noris) #6

Hi @Tor_Gunnar_Berland,

Have you by any chance upgraded any OSX components such as your Operating System recently? It is certainly strange that this issue just popped up out of nowhere and that using parallels works as expected.

Are you able to use Go -> Connect to server -> Connect as Guest to still connect to your Nucleus or is that not working as expected as well?

Thanks,
Noris


(Tor Gunnar Berland) #8

I can connect to it via “connect to server”, but I need to use nucleusplus.local; it is listed under network in finder as nucleusplus (without the .local).


(Tor Gunnar Berland) #9

A restart of macOS did not fix it. Rebooting the Nucleus+ actually did. I have no clue why?
But all good now


(Noris) #10

Hi @Tor_Gunnar_Berland,

Glad to hear that the issue is resolved after a Nucleus reboot! I’m not quite sure why it occurred, is the Nucleus using a reserved IP address in your router configuration? I am thinking that the IP address may have changed and OSX was trying to resolve the previous IP but could not do so.

Thanks,
Noris


(Tor Gunnar Berland) #11

My nucleus+ is on a fixed ip address; so that will never change.
Accessing it through browser on same computer always worked (using name).


(Mike) #12

I think it’s an OSX issue. Sometimes I don’t see it in the finders “Network” section, but “Go > Connect to Server” (command-K) always works.


(Noris) #13

Hi @Tor_Gunnar_Berland,

Thanks for confirming that the Nucleus is on fixed IP. If this issue occurs again do let me know, but yours is the first report I’ve seen regarding this behavior. How often does this issue occur for your @MJB?

– Noris


(Mike) #14

I’ve never really checked, but often after waking from sleep - perhaps once or twice a week. Command-K allows me to reconnect, and re-populates the Network side bar.


(Noris) #15

Hello @Tor_Gunnar_Berland & @MJB,

I brought up this issue with the dev team today and they have indicated that they haven’t previously seen this behavior in the lab. This might be due to a networking issue or the mac itself, but it is not clear yet why this occurs.

@MJB - When this issue occurs next, can I please ask you to open Console.App on Mac, press the Nucleus button on the side and then save the outputted log file and send it to us? You can perform the same set of steps @Tor_Gunnar_Berland to get this diagnostics information over to us.

Feel free to drop this console output in a shared dropbox, google drive or firefox send folder and I can pass it on to QA to take a look.

Thanks,
Noris


(Tor Gunnar Berland) #16

I have multiple other network devices without such issue (never). My mac is a fairly new iMac Pro which have worked flawlessly since installed. Network has also been perfect for all other devices. So everything is pointing to the Nucleus+ here. But I will check if it happens again and push the log file to you guys.

Not seen this since it happened, and my Nucleus+ is always turned on.