Unable to add network share after Router update

Nucleus Core. Asus AC3000 Router (x2). Both connected via Ethernet to home network. Modern is Telus T3200. Limetree Bridge (Roon Ready). B&W Formation Wedge (Roon Ready). Bryston B 100 integrated amp. Audio sources: Naim UnitiServe and Tidal. Total tracks 5000+.

Roon was not working. But that problem was solved when I updated the firmware on my Asus routers.
But since then Roon is not recognizing my Naim UnitiServe, which holds about 200 CDs. I have tried adding a network share using both the IP address of the UnitiServe and the name of it. (For example: \NSSRV83DC\music or \share). I either get an immediate message of an “unexpected error” or the Roon icon appears with the word “Adding”, but after about 10 minutes I get the message “Could not connect to share. Unauthorized.”

Hi @Laurie_Long,

I will be happy to help you with this.

I have seen this happen before and it’s a matter of an initial authentication. Do you have a Windows or Mac machine that you can try accessing \NSSRV83DC\music or \share from? When doing so, please type guest as the username and leave the password blank assuming you’re prompted.

Please let me know!


Hi Wes:

I solved my problem a few days ago with the help of my local Roon dealer. When I first tried to add a network share it didn’t work. My dealer suggested trying again - but instead of leaving the username and password blank I used “admin” and “admin”. That worked so all is good now.

1 Like

I’m glad to hear that! Enjoy the music!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hi @Laurie_Long,

I got your message and have reopened your thread here.

Does it help to add the network share with the username Guest and provide no password?

Also, is the share accessible from your computers on your network or is it just an issue with Roon?


Hi Wes: I’ve tried two similar approaches. I enter my router’s IP address \\Music using “admin” as the username and password – and the same IP with “guest” as the username and NO password. Both give the same result: the Roon icon and the word “Adding”, which goes on for hours with no result. If I want to try my MAC as the Roon Core, should I disconnect my Nucleus?

As an aside the “adding network path” Help Page gives instructions for MACs and Windows but I can’t find any instructions for when using a Nucleus as the Roon Core.

One further note: When I select “storage” from the menu, the page displayed lists three drives that are “not available. Check the drive or edit this folder if it’s been moved.” For example \NSSRV83DC\Music. But when I select “edit this folder” it takes me to a “Choose music folder” page that shows two folders on the left, but on the right “Error loading folder. Not Available.”

Here’s what I see in some of the logging:

11/09 21:59:40 Info: [broker/locations/directorystoragelocation] initializing FileBrowser.Entry:  MusicFiles1, WD My Passport 0741 : /Music, drive availability is: False
11/09 21:59:40 Info: [broker/locations/directorystoragelocation] initializing FileBrowser.Entry: \\NSSRV83DC, Music : \, drive availability is: False
11/09 21:59:40 Info: [broker/locations/directorystoragelocation] drive is not available so disposing resources (if they exist): FileBrowser.Entry: \\NSSRV83DC, Music : \
11/09 22:23:14 Debug: [broker/filebrowser/drive] GetEntries: failed because drive has no root (yet?). Probably because volume is not available: \\NSSRV83DC Downloads.

While it might be confusing to many (me too at times!), the errors indicate that the drive is just not available.

Can you give me a screenshot of what you see under Roon>settings>storage? (as I was typing this you kind of painted this picture for me).

I am not certain you answered this though. Can you access those music folders from devices outside of Roon?


First, some good news. It turns out I might have been using an old IP Address. I have successfully added SOME of my files using \IP Address\Music with “admin” as the username and password. Unfortunately another path \IP Address\Downloads is not working – giving me a message “could not connect to share. Host not found.” I’m including the screen shot you suggested although it has changed for the better. Any suggestions most appreciated. I will try the MAC option later.

Hi @Laurie_Long,

These storage issues can be fun. Let’s go with fun!

What is the MusicFiles1 folder? Is it a share on an internal storage drive or externally connected to Nucleus? I am seeing failures in reaching this location within diagnostics logging.


I don’t know what the MusicFiles1 folder is. (I’m not too “tech-savvy”). When I first started using Roon, I briefly used my MacBook Pro as the Roon Core. But I bought a Nucleus and everything has worked well until a couple of months ago. As far as internal storage is concerned, I use only my Naim UnitiServe that holds ripped CDs and Downloaded music files. (I also subscribe to Tidal).

I’ll let you know if I make any progress. In the meantime, please keep the suggestions coming.

You are doing great, @Laurie_Long, and are pretty savvy to have the setup you do!

In logging, it looks like MusicFiles1 is a WD external drive. If it’s no longer employed you might want to remove it from the storage locations in Roon.

If you can get it to where that other storage location you’re missing access to is visible from any other networked computer it should start working within Roon.

I was doing some research and came across some threads with Naim. I didn’t find anything specific but found that @CrystalGipsy might have some experience here. @CrystalGipsy, what do you think?


I don’t have any Naim server gear but they have always been a problem mounting them in Roon plenty of posts on here about them. You have to follow a specific way. Sorry can’t really help more than that.

Hi Wes/Crystal/Gypsy: Good news. I don’t know exactly why but everything is working again. Under Settings>Storage I noticed an \IP Address\Downloads folder was showing (even though I had been trying unsuccessfully to add it). So I selected the folder and hit “Add” and about 300 additional tracks were back in my Roon library. Go figure!

Thanks again for all your help.


@Laurie_Long I think this is great news. Please let us know if you have any further issues.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.