Unable to add network share on QNAP NAS

I have my Roon Server running on a Synology DS220+ with 6GB of RAM. I know this is not recommended but I have not experienced any issues so far. I have around 30,000 tracks and do not use any DSP.

I am trying to add a backup drive on my old QNAP TS-509. I have read all the instructions to create the share drive. I can mount this share on my Mac using smb://sharename/directory using a user created just for this. I have also enabled SMB3 on my TS-509 using the smb3enable command and have confirmed it is running using the smb2status command.

I keep getting the unknown error each time I try with either with IP address or device name. I also tried different usernames, passwords, including one with full admin rights.

This is what I see in the log file:

11/30 10:22:31 Debug: [easyhttp] [91665] POST to https://discovery.roonlabs.net/1/query returned after 961 ms, status code: 200
11/30 10:22:39 Debug: [roon/cifs] tryremount, path: \\iguoh-nas01\RoonBackup, username: roon, password 8 chars
11/30 10:22:39 Debug: [roon/cifs] mounting \\iguoh-nas01\RoonBackup
11/30 10:22:39 Debug: [roon/cifs] alreadymounted? //iguoh-nas01/RoonBackup => false
11/30 10:22:39 Debug: [roon/cifs] alreadymounted? //iguoh-nas01/RoonBackup => false
11/30 10:22:39 Debug: [roon/cifs] cleaning mount points: /mnt/RoonStorage_*
11/30 10:22:39 Trace: [roon/cifs] Got exception trying to create mount directory, retrying with sudo mkdir.  Exception message: System.UnauthorizedAccessException: Access to the path '/mnt/RoonStorage_7593effca72b60513ae8ed4e7f4d9ba80e915782' is denied.
 ---> System.IO.IOException: Permission denied
   --- End of inner exception stack trace ---
   at System.IO.FileSystem.CreateDirectory(String fullPath)
   at System.IO.Directory.CreateDirectory(String path)
   at Roon.CIFS.CIFSUtil._CreateDirectory(String s)
11/30 10:22:39 Debug: [roon/cifs] domount: PASSWD="******" sudo -nE /sbin/mount.cifs "//iguoh-nas01/RoonBackup" "/mnt/RoonStorage_7593effca72b60513ae8ed4e7f4d9ba80e915782" -o guest,nounix,iocharset=utf8,user="roon",domain="WORKGROUP",vers=2.1,uid=177843,gid=177843
11/30 10:22:39 Debug: [roon/cifs] returned 1: sudo: a password is required
11/30 10:22:39 Debug: [roon/cifs] PASSWD="******" sudo -nE /sbin/mount.cifs "//iguoh-nas01/RoonBackup" "/mnt/RoonStorage_7593effca72b60513ae8ed4e7f4d9ba80e915782" -o guest,nounix,iocharset=utf8,user="roon",domain="WORKGROUP",vers=2.1,uid=177843,gid=177843 failed: (1): sudo: a password is required
11/30 10:22:39 Debug: [roon/cifs] domount: PASSWD="******" sudo -nE /sbin/mount.cifs "//iguoh-nas01/RoonBackup" "/mnt/RoonStorage_7593effca72b60513ae8ed4e7f4d9ba80e915782" -o guest,nounix,iocharset=utf8,user="roon",domain="WORKGROUP",vers=2.0,uid=177843,gid=177843
11/30 10:22:39 Debug: [roon/cifs] returned 1: sudo: a password is required
11/30 10:22:39 Debug: [roon/cifs] PASSWD="******" sudo -nE /sbin/mount.cifs "//iguoh-nas01/RoonBackup" "/mnt/RoonStorage_7593effca72b60513ae8ed4e7f4d9ba80e915782" -o guest,nounix,iocharset=utf8,user="roon",domain="WORKGROUP",vers=2.0,uid=177843,gid=177843 failed: (1): sudo: a password is required
11/30 10:22:39 Debug: [roon/cifs] domount: PASSWD="******" sudo -nE /sbin/mount.cifs "//iguoh-nas01/RoonBackup" "/mnt/RoonStorage_7593effca72b60513ae8ed4e7f4d9ba80e915782" -o guest,nounix,iocharset=utf8,user="roon",domain="WORKGROUP",vers=1.0,uid=177843,gid=177843
11/30 10:22:39 Debug: [roon/cifs] returned 1: sudo: a password is required
11/30 10:22:39 Debug: [roon/cifs] PASSWD="******" sudo -nE /sbin/mount.cifs "//iguoh-nas01/RoonBackup" "/mnt/RoonStorage_7593effca72b60513ae8ed4e7f4d9ba80e915782" -o guest,nounix,iocharset=utf8,user="roon",domain="WORKGROUP",vers=1.0,uid=177843,gid=177843 failed: (1): sudo: a password is required
11/30 10:22:39 Debug: [roon/cifs] Mount deleting: /mnt/RoonStorage_7593effca72b60513ae8ed4e7f4d9ba80e915782
11/30 10:22:39 Warn: [roon/cifs] failed to connect to CIFS storage: sudo: a password is required

I do not quite understand the part on unauthorised access as well as the part on “sudo: a password is required”. The user I created already has a password and I included it in the Roon app when creating the backup drive.

I have been trying to figure this out for days doing Google searches and all and just could not find a resolution. Has anyone encountered this and found a solution? Thank you very much.

Disclaimer: I’m no network expert!

Not sure I understand your scenario. Do your NAS’s have the ability to connect via USB? You could then setup the QNAP as Directly Attached Storage and the Synology would just backup to it simply treating it as an external drive.

I have a QNAP and use USB drives for backup. One is a QNAP DAS with four bays. It just connects to the main NAS by USB and it is seen in file manager as well as the backup program.

Unfortunately, I do not. They are located in different places. Maybe I should try your suggestion by using a portable USB drive for back up.

This pretty clearly states that whatever user the RoonServer process runs under does not have the permission to create a directory under /mnt/. So this is not an issue with the share. Why your installation of RoonServer has insufficient rights is unclear. How did you install it?

I downloaded the DSM7 installer from roononnas.org and installed it using a username with admin rights. RoonServer is a service user so I do not know how to fix any access rights issue as I cannot find it in DSM though I see it in /etc/passwd.

Everything else seems to be working fine.

I found RoonServer under system internal user and checked that it already as read/write permissions to the RoonServer shared folder. What else do I need to grant it read/write permissions?

Let’s invite @crieke as the maintainer of the RoonServer package. Maybe he is able to help you further with your issue.

@Ivan_Guoh, from your first post I understand the following. Your Roon Core is running on your Synology DS220+ running DSM7 and you want to write Roon Backups to a your QNAP TS-509. You are trying to create a share to your QNAP within Roon.

If that’s the situation: it’s not possible. In DSM7 within a package you no longer can create an SMB share to an other device.

Try the following. In DSM go to File Station. Within File Station mount the remote folder on your QNAP to your Backup folder on the DS220+ (Tools->Mount Remote Folder). Furthermore be sure that the internal user “roon” on your DS220+ has read/write permission on that Backup folder. Now in Roon you can create a backup to the Backup folder on the DS220+ (which by the mount in fact is a folder on your QNAP).

I have the same kind of setup. To be sure I placed my backup folder in the Roon share on the DS220+. In that share I have to subfolders: the RoonOnNAS folder and a Backup folder.

I hope this helps you further.

Thanks @Alfred_van_Hoorn for your detailed post. Your understanding of what I am trying to do is spot on. It also explains why I am not able to do what I am trying to do. I tried your suggestion to mount the remote folder from File Station but for some reason, I am not able to as well (I can mount the same folder from my Mac). I will try to troubleshoot from here.

For now, I have connected a portable USB drive to my DS220+ and do what @pstrisik suggested. It works and is probably a much simpler solution. Should I need to migrate to a NUC later, I will just connect the same USB drive to the NUC and restore.

Many thanks to everyone for your help!

@Ivan_Guoh, thanks for your compliment!

I have one more suggestion to solve the issue. How have you setup SMB in your DS220+ (Control Panel → File Services → SMB tab → Advanced settings)? What on the DS220+ are you using as minimum and maximum SMB protocol and is QNAP using an SMB protocol which lies within this range?

Thank you for the suggestion. I just tried this and it does not work as well. I set the DS220+ to min SMB2 and max SMB3. The QNAP is a lot older so I had to use the command line smb3enable. I will probably just stick to the portable USB drive since I have a spare one and it is not being used anyway.