Unable to authorize Roon core

Core Machine (Operating system/System info/Roon build number)

MacPro Catalina/

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Mac ->ubiquity switch->ubiquity gateway->xfi cable modem

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Transporter

Description Of Issue

The problems keep escalating. Roon has been very unreliable on my system since I started using a Mac pro. Problems include many instances of iPad remote to connect to core until the core is restarted, failure to login to qobuz until the core is restarted, iPad remote app crashing iPad OS, and now the Roon core has deauthorize itself and will not reauthorize even though the credentials work ok on the Roon website. I love the features and interface, but the reliability is unusable.

Hi @Leslie_Kohn,

Welcome to the forum! These symptoms sound very strange, can you please use these instructions to send me a copy of your Roon logs? I’d like to take a look to see what’s happening in them. Thanks!

Not sure if you got my direct reply, but here is the log file: https://drive.google.com/file/d/1WDYArpXuYSxiWXLB-v8SNGs27-zUhPa-/view?usp=sharing.

Looks like something was fixed and I was able to reenable my Roon core. I I am still having a problem where Qobuz always stops working 1-2 hours after I start the core (can’t play any Qobuz content, can’t display my Qobuz or overview views). Restarting the core only fixes the problem for 1-2 hours.
Also the iPad remote app is crashing IOS once per day.

Hi @Leslie_Kohn,

I’m taking a look over your logs and I’m seeing quite a few web exception without response: : System.Net.WebException: The operation has timed out. errors contained in them, it doesn’t look like you have a stable connection when attempting to communicate with our servers or with Qobuz’s servers.

Just to clarify here, the Mac is connected via Ethernet to the switch? Or are you using WiFi?

Managed switches have caused issues with Roon in the past, so if you can bypass the switch and plug in directly to the router or to an un-managed switch instead, that would be a good test.

Networking Best Practices Guide

Managed Switches

Managed switches can be very robust, but they are often designed for professional installation, so in many cases the out-of-box configuration is not right. If your switch has a “flow control” setting, please make sure that it is enabled. Also, make sure that the switch is not performing any sort of throttling that might impact communication between cores, storage, remotes, and/or audio endpoints. Finally, ensure that the switch is configured to pass multicast and broadcast traffic. If in doubt about any of this, try temporarily replacing your managed switch with a “dumb” switch to see if things improve.

The core is connected by Ethernet to the switch and Ethernet to the player. There is no WiFi involved. The network connection is fine for all other applications including video streaming and I have a 1 gigabit per second internet connection. Indeed, Roon itself works OK for the first hour or two after I restart the core, and then Qobuz stops working. At the same time Tidal is working fine. This leads me to believe that the problem is with the way that Roon is using the network rather than the network itself. Let me know if I can provide any more information.

I checked my switch settings and turned on flow control. That didn’t help anything.

Hi @Leslie_Kohn,

Thanks for giving those suggestions a try.

If instead of restarting the Core, you disable/enable your Ethernet adapter, does that also allow Roon to work as expected?

Let’s try to get the managed switch completely out of the picture as a test, can you try to temporarily connect via WiFi or directly to the router to see if the issue is the same?

I tired both suggestions.
Disconnecting and reconnecting Ethernet and wifi after qobuz stops working didnt help.
I then replaced the ubiquity switch and the ubiquity gateway with a simple switch and restarted the core. After about an hour I could no longer see my overview screen, my qobuz view or select new qobuz content. The current qobuz stream was still playing. I think it’s clear that the problem is with the way Roon is running on my Mac.

Hi @Leslie_Kohn,

Do you by any chance have a phone with hotspot capabilities? If so, can you please try connecting to your phone and verify if you’re still seeing the same issues? When I looked at logs there were quite a few networking errors, and the network remains my primary suspicion.

I tried using my phone after the core couldn’t login to Qobuz. That didn’t fix anything. Once the core gets into that state it must be restarted to get Qobuz login to work. Ar the same time I have no problem using Qobuz from my iPad app. Maybe there is something in Roon which is triggered by unusual Qobuz behavior.

Before Qobuz stops working completely, I am also seeing Roon jump to the next song before reaching the end of the current song. This usually happens near the end of the song.

Hi @Leslie_Kohn,

Was this in hotspot mode (with the Core connected to the phone’s network) or was this still on the same WiFi?

The Core handles communication with Qobuz, so if you are still on the same network it wouldn’t be surprising to see the same issue on the Core + also on the remote.

Do you have hotspot capabilities on your phone or can you try the Core on a different network? I’d also advise changing your DNS servers to Cloudflare DNS, Quad9 or Google DNS in case that helps.

I was using the hotspot on my phone for the core, sorry for not making clear. This only occurs with Qobuz In Roon and not tidal in Roon and not Qobuz In the Qobuz application and is fixed for 1-2 hours restarting the core. IMHO this makes it a Roon problem and not a network problem. The behavior including error messages is similar to Tidal and Qobuz has stopped working, except that only Qobuz is affected and restarting the core temporarily fixes the problem. Is there anything in the Roon server side that could be causing this problem?

Hi @Leslie_Kohn,

Thanks for confirming that you used the hotspot, and for giving it a try. It is certainly strange that you saw the behavior on both networks.

Did you disable the connection to your previous WiFi network (depending on if you connected the hotspot via USB cable or the WiFi hotspot of the phone, it was possible both were active at the same time)?

I would also try a reinstall of Roon in case the current database is related, can you please give this a try?

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the fresh database reproduces the issue (without restoring the backup for now)
  • If the issue is fixed, only after try restoring the backup

I was using wifi for the hotspot connection with ethernet disabled so there was no other internet connection.

I tried your suggestion of reinstalling Roon with new database. After running for about one hour without playing anything, I am having the same problem with Qobuz not working (Overview and My Qobuz take a long time to update, and get “error loading page” message) and I can’t see my Qobuz favorites.

I noticed that after restarting the core, the sync indicator for Qobuz in the Setting/ services tab is on for about a minute, while Qobuz is working initially. It goes off for about one minute, and then it comes back on. At that point Qobuz stops working as described above. If a Qobuz stream was playing before that point it will continue to play for a while so things eem ok but the start of problems is happening much faster than I described.