Unable to connect Roon android app to Roon core

Core Machine (Operating system/System info/Roon build number)

OnePlus 3T Android version 9 and PC Windows 10 Home 64 bit

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Virgin Media Hub 4 wi-fi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonos in 7 rooms

Description Of Issue

I have enabled access for Roon in the Windows firewall and the app can see the PC. It is constantly attempting to connect but is unable to do so. There is an amber dot with Connecting...' which changes a red dot and Connection Failed’, then the cycle repeats continually.

I forgot to state that remote connection is set up and the phone and PC are on the same network.

Hi @Peter_Allen,

Was this device able to connect previously or has this always been an issue with this device?

Are other remotes able to connect?

Hi, thanks for your reply. I have only just downloaded and installed roon as a result of the Black Friday promotion. So this is the first time I attempted to do this. Unfortunately, at the moment I don’t have any other devices that I could try to connect. I am expecting to receive a new tablet in about a week’s time so I will be abole to try that, but I was hoping to fix it before then.

Hi @Peter_Allen,

On the PC itself is everything working okay when using Roon?

Hi Dylan. Yes, nothing on the PC seems to be affected.

I don’t know whether this helps, but I’m having the same problem with my Oneplus6, connecting to my Roon core on Windows 10. All my other remotes including iPad, Macbook pro connect with no issues.

Hello @Peter_Allen, When you’re on the “Choose your Roon core” screen, you should see a “help” option that will allow you to enter your core’s IP, or try entering as the core’s IP. If you do this, are you able to make a connection?

1 Like

I’ve just bought an Amazon Fire tablet and I tried to connect with that, but the result was exactly the same as with the OnePlus, so it looks like the OnePlus isn’t the cause in this case.

Thanks Nuwriy. I’m having trouble finding the `Choose your Roon Core’ screen. The core is currently connected to my PC. Do I have to disconnect the PC from the core in order to bring it up?

Yes @Peter_Allen, my apologies for the confusion. Please hit choose another core on the remote to get to this screen. It comes up before you’ve tried to choose a core.

Sorry, I misunderstood. I had already typed the IP address into the Help box. What happens is that there is a yellow circle and the word Connecting...', folowed by a brief flash of a red circle and the words Connection Failed’. This continues ad infinitum with no progress.

Hello @Peter_Allen, does that happen if you enter the multicast address as well? Could you please try this again and reply here with a timestamp (in your local timezone) when you do so I can enable diagnostics for your device? Thanks!

Hi nuwriy, the problem has resolved itself now. I had an electrical problem which meant that wi-fi was down. After it was resolved and the wi-fi was back on the OnePlus connected to Roon without any problem (so far). I don’t know why this happened but I’m happy with the outcome. Thanks for your help.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.