Unable to connect share storage or backup from Roon after update

OS Ubuntu Server 16.04 LTS Roon Server STATIC IP
Roon 1.7 (build 500) - error checking for update
NAS - Freenas FreeNAS-11.2-U6

Router - hitron whatever cable company router.
Roon Server on wired connection. STATIC IP
1 Switch HP 8 port 1GB/s
Wifi is on use it to control via mipad, phone and other devices.
Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Mix of things
3 Airport Expresses - all wireless
1 Riopeee RaspPi with Allo Boss - Ethernet connected.


All went well for months except i could never backup to my NAS. I can save/create and edit files from everywhere. Roon had an issue connecting to Shares on my Freenas. Not sure why. I don’t really worry to much about that its a database and can be rebuilt. I think I got one this morning saved to the Roon Server root drive
Update today and I noticed that I was only playing Tidal copies of songs. Went to play a local file and it would not play. Then checked the Storage and both folders (i have a separate Podcast folder) were not connected.
Now ROON can’t see anything - I have even tried connecting to a mac share and a Windows share with no luck

When i search for Roon OS devices to configure my server does not come up. Just keeps searching for devices. Even disconnected and reconnected tot the server a few times.

Not too happy right now.

And now no Tidal though I can use the web player. So no music at all - Radio doesn’t work either.

Hi @Bruce_Klock,

Sorry to hear about these difficulties.

Can you please share a these instructions of your Roon Settings -> Storage tab? How are you connecting to your FreeNas, are you using Hostname or IP Address? If you are using hostname, is there any change with using IP address instead?

I’m not sure what you expect to pop up there. The searching for RoonOS devices apply only to ROCK and Nucleus. If you don’t have either of these devices on your network, it will remain empty.

Have you tried rebooting your Core yet? I would give this a try first. If the behavior is still the same, please reproduce this issue and let me know the exact local time + date in your country you notice this behavior occur at.


rebooted core - many times
Understood about Roon OS devices.
screenshots shared for both IP and hostname share attempts. And I can connect to them from both mac and windows machines on the network, create files and folders and delete. Roon won’t find them.

Time of disconnect to local roon/freenas share approx 3 PM mountain time

And TIDAL is back now.

Hi @Bruce_Klock,

I have activated diagnostics mode for your Core and what this action does is automatically upload a set of logs to our servers for analysis. I am looking through them now and I notice the following error when trying to mount your share: failed: (32): mount error(13): Permission denied

It looks like for some reason Roon on Unbuntu is not able to properly connect to this share. I would suggest the following:

  1. Try using the smb notation instead of just the backslashes. This would be smb:// or smb://freenas/music according to your screenshots.

  2. Reboot the Core, NAS and Networking Gear.

  3. Verify that you have the SMB permissions properly set on your NAS and that the folder name is correct. I have found similar issues discussed in this forum (might help).

  4. Simplify the network. I see that you have multiple networking devices here, not sure if your Airport expresses are being used at any point, but I would try connecting both your Core and your NAS to the router as a test.

I finally got to this this weekend. Issue resolved with adding an external hard drive that handles the library. For the life of me smb on my Freenas won’t handle sharing to roon. Windows, Mac and Linux all connect fine.
Took the opportunity to upgrade linux to Ubuntu 18.04 LTS. However as of this morning I can’t play anything, Internet radio, local files in the library or Tidal. I hit the play button and nothing happens. rebooted the computer plays for a bit and then it happens again.

Just stopped again 39:12 into a library track after a reboot. same issue - it just doesn’t want to play.

sudo systemctl stop roonserver
sudo systemctl start roonserver

allows me to start again without rebooting.

Restarting all endpoints solved the issue and it plays fine now

1 Like

Hi @Bruce_Klock,

Thanks for the update, glad to hear that the system is stable since adding the external drive and rebooting your endpoints!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.