Unable to connect to Freenas SMB share

Core Machine (Operating system/System info/Roon build number)

ROCK Version 1.7 (build 537) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet 1 Gb/s, Fixed IP on ROCK and on Freenas. All HW on the same VLAN and Subnet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Bluesound, but they work ok

Description Of Issue

I have been trying all sorts of paths to connect to a SMB share on a FreeNAS-11.3-U1 installation. I can connect to it from Windows without problems. I have tried both the way I connected to a Windows 10 share before, ie \host\share and the SMB way smb://host/share, smb://host//path/share, smb://IP/share in all sorts of combinations. I have created different users to the share on Freenas, tried root user, my windows ID/pw, and made a separate Roon user/pw. I have tried with and without user and password information without luck. Has anyone else managed to do this? Is it better to create an NFS share in Freenas for the ROCK to connect to or what is the recommended way?

What is min. SMB protocol version (should be < 3.0 AFAIK)?

I tied to google but didnt find any good info. Freenas uses Samba.

Yes that’s expected. And SAMBA has options. Min and max protocol version is a set of them. As these may be important, NAS operating systems usually allow to set these somewhere. Please check. I don’t have FreeNAS so I can’t be of more help for this specific task.

Update: https://www.reddit.com/r/freenas/comments/7n8c9a/freenas_111_where_is_the_smb_minimum_protocol/

Disclaimer: I’m just another Roon user trying to help you, not an official representative of Roon Labs.

Pretty sure as a server rock only supports SMB V1 so this might apply to outbound too.

I found a way to allow SMB 1 but it didnt help. I also upgraded Freenas to FreeNAS-11.3-U2.1 which contained a Samba update to Samba 4.something. But no luck.

Does this mean that you have successfully connected your ROCK with a share on a Windows 10 machine? If not, you should try that.

Can you connect from the Windows 10 machine to the ROCK?

Can you connect from the Windows 10 machine to the FreeNAS server?

Yes I had my music share on a Win10 machine before and had no trouble connecting it. I can connect to ROCK from Win10 laptop yes. Yes, I manage Freenas from a web gui on any machine and I can map and mount the Freenas SMB share in Windows. its just Roon ROCK that doesnt want to find the share.

Where is ROCK installed? Is it running in a Docker or VM on FreeNAS?

I am not an expert here by any means but I just checked and I am able to point the “add folder” in “storage” in Roon on my Rock/NUC to my FreeNAS running -11.3-U2.
Looks like this:

It is in the process of updating right now. but when that is done I can look at he settings for the share or whatever you may need to try to figure it out.

1 Like

BlackJack, it is on a NUC, separate to Freenas

1 Like

Thanks BearFNF. I tried making a new SMB share and set up a dedicated RoonUser and managed to map it from ROCK. I didnt use the full path, Only SMB://Freenas/SMBshare, not the dataset information that Freenas has in their path guide


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

ROCK supports SMB V2.

% smbutil statshares -a

SHARE                         ATTRIBUTE TYPE                VALUE
                              USER_ID                       501
                              SMB_NEGOTIATE                 SMBV_NEG_SMB1_ENABLED
                              SMB_NEGOTIATE                 SMBV_NEG_SMB2_ENABLED
                              SMB_NEGOTIATE                 SMBV_NEG_SMB3_ENABLED
                              SMB_VERSION                   SMB_2.002
                              SMB_SHARE_TYPE                DISK
                              SIGNING_SUPPORTED             TRUE
                              EXTENDED_SECURITY_SUPPORTED   TRUE
                              LARGE_FILE_SUPPORTED          TRUE
                              FILE_IDS_SUPPORTED            TRUE
                              DFS_SUPPORTED                 TRUE