Unable to connect to ROON core via OS devices

I added a reply to another post -but am having my own issues with this. I last used ROON successfully on the 15th of April. On returning home after a short break, I am unable to “find” the Roon core on any of my devices [use OS] although the core is clearly visible on my network. Have tried re booting the core, the internet, the devices and also tried reloading Roon on my mac. Core is still visible on my network -but Roon won’t find it. I also disconnected 2 of the portable HDs - but still no luck.
Not sure what to do next.

Only thing I’ve not done is reinstall operating system on my Core. That feels a bit too scary as I’ve no idea how to reinstall it.

Can you first clarify what device your Roon Core is running on? E.g. a PC, Mac, Nucleus, ROCK/NUC or NAS? Thanks.

You say you can’t connect with any of your devices which “[use OS]”, so not sure what “OS” you have tried, MAC OS, Android OS, iOS, Windows OS? It looks like you are asking about Rock, is it on a NUC? It also looks like you have tried a Mac? Have any updates been applied on your MAC since you were away? May be a firewall/security setting?
If it is on ROCK/Nuc, can you get to the Web UI for the Rock device?

I think its a ROCK as that is what it says on my network. Roon optimised core kit -although not sure that’s helpful. This is in my finder -on network it that helps.

It is I believe on a Rock?Nuc -how would I get to the Web IU for a Rock Device?

Easiest way is to enter the IP for the Rock in your web browser.
Should get you to a page something like this:

I have done that -and the option to reinstall comes up…but I’m reluctant to do that as worried I’ll mess up the whole thing. Also when used finder it says its on a PC-although I thought it wasn’t so getting a little confused here.
That is the page that comes up though.

Can you post a screen shot of what you see? Does it say the server is running?
Have you updated all your remotes lately? There have been some updates released recently and all of the remote machines will need to be on the latest release.

What does Roon show when you try to connect?

Does this help?

This is what Roon says.

And this is what happens when I click on the optimized core bit.

Which as far as I can tell suggests all in order.

Sorry bit useless at times with IT.Last update I did do it for all devices as this seems sensible. I hope the screenshots bring a little light to the problem.
Thank you bear FNF and Geoff_Coupe for their advice so far.

Might try this:

Thanks but Roon already allowed by Firewall.

In the screenshot of the ROCK’s Web Administration page, there’s something a little odd. The Operating system has been running for over 2 hours, but Roon Server for only 12 seconds. Did you click the Restart button of the Roon Server in that screen?

I think I did. I’ve been trying various things for a while. Would it help for me to switch off the core again - and then turn it back on -so I could do another screenshot?

Turned it on and off…and screen shot.

Just looked again - and here’s a further screen shot…is that helpful?

I had the same problem and reinstall Roon OS helped.


Make sure you have a good backup, and then try resetting RoonServer by following the directions here under the ROCK section.

Yes - it looks as though your Roon Server keeps restarting. Follow @Rugby 's suggestion and try a fresh database (if you have a backup to restore afterwards).