Unable to Connect to TIDAL/Reinstalling RoonServer on Synology

I have an active TIDAL account which works fine outside Roon. I had it linked and connected in Roon, but now it won’t login and connect. When I click the login button, it opens a browser window in which I can Login to TIDAL again and its says “You’ve successfully connected your TIDAL account”. Going back to Roon, it still is not connected. The problem has persisted for 3 days now. I have read several posts and tried several solutions, but none worked. HELP!


I’ve moved your topic to the support section of the forum.
In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

I’m running the Roon app on my desktop PC (Windows 10, 64bit), laptop, iPad and iPhone. It has been running fine with TIDAL connected. It is still working fine, but I am no longer able to connect to TIDAL. My TIDAL account is active and works fine through the separate TIDAL app. As my main audio device, I am using the Cambridge network streamer CXN V2. My own music files run from a NAS server (Synology) and working fine. Hope this helps in analyzing the issue.

The issue: " I had TIDAL linked and connected in Roon, but now it won’t login and connect. When I click the login button, it opens a browser window in which I can login to TIDAL again and, once doen, its says “You’ve successfully connected your TIDAL account”. Going back to Roon, it still is not connected. The problem has persisted for 4 days now. It did work all well before."

I’m having a similar problem … while I can access Tidal on tidal.com/Tidal App, Roon won’t load Tidal content (on the overview page). Using the search function or searching by genres, Tidal content is displayed, but I cannot play any music, it just doesn’t start.

I tried to deactivate and reactivate the Tidal service in Roon, but now I’m not able to activate it. A click on ‘activate’ doesn’t result in any change, it stays deactivated.

I dis- and reconnected to Tidal, it works now! But: it’s very very slow. So something’s definitely up.

Not quite the same problem that I have where I cannot login to TIDAL through Roon at all.

Hi @LJB,

Can you please try clearing out your TIDAL cache?

  • Exit out of Roon
  • Find and open your Roon database
  • Navigate to Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

I would also ensure that you have the latest version of Roon installed, you can find the build number under Roon Settings -> About and it should list build 555.

Thanks. I already had the latest Roon version installed. I cleared out the cache and restarted Roon. No change re. TIDAL Login, issue remains. By the way, cache remains empty after one restart of Roon, that right?

A post was split to a new topic: Cannot login to TIDAL - Windows 10 + Android

Hi @LJB,

Thanks for giving the cache clear a try.

Do you notice the same behavior if you try using any other Roon Remotes (iOS/Android/Another PC)? Have you ensured that you’re running the latest Roon build (build 555)? This should be listed under Roon Settings -> About.

What kind of browser window is opened? Chrome/Firefox/Internet Explorer? Are you using the latest version of the browser?

Yes, I use the latest build. Same behavior on all devices. Not connected to TIDAL and not able to login and connect. Or, the login process gets started OK by directing me to each browser (Chrome on my desktop and laptop, and Safari on the iPhone and iPad). On each browser, I can enter my TIDAL username and password and I get the success message "“You’ve successfully connected your TIDAL account”. When then returning to Roon, TIDAL remains unconnected. I am so puzzled because it all worked so well until a few days ago.

I had a problem with Roon (related to TIDAL) and thought to deinstall the whole Roonserver App and reinstall it might be worth another try. But now, after deinstalling Roonserver, I am not able to reinstall it again. There is a shared folder named roonserver on my Synology NAS (in fact, on an external SSD that is attached and where Roonserver was installed before and worked). But the installation of the SPK file (provided by Christopher Rieke) stops with the following message:

/tmp //could not download installation archive from roon labs website. please check your internet connection

The internet connection is certainly not the problem.

I would appreciate any help. Thanks.

I will move this to support as more people will see it there.

Hi @LJB,

Did you use the instructions provided by @crieke to install the package? See:

Yes, I did. And as I said, I had it previously installed on the same USB drive name roonserver.

This is confusing. What USB? It thought you said it was a Synology.

Apologies if I did not express myself clearly. It is an SSD connected to the Synology NAS via USB and the drive is named roonserver. And roonserver worked form it before. It is just that I uninstalled it and am now trying to reinstall.

As I believe it is recommended to install roonserver not directly on the NAS itself for better performance in reading and playing the music files that are on it.

From Roon’s Knowledge Database:

Which NAS devices are supported?

Most QNAP, Synology, and Asustor devices with a 64-bit x86 CPU, like Intel or AMD, and at least 2GB RAM are supported.

We strongly recommend 4GB of RAM and an SSD for the Roon databases . Your music files can be on spinning disks, but ideally the Roon database should be on an SSD. This one optimization can provide the single biggest improvement to Roon’s performance and user experience.

Note: If your NAS does not have a free slot for an SSD, you can use a SSD via an external enclosure connected via eSATA or USB 3.0. Anything 64GB or larger should be fine

Depending on the NAS, it can more than handle Roon requirements. We are running a Roon Server and Plex Server on the same box with rotational drives.