Unable to connect with nucleus plus

Roon Core Machine

Nucleus plus

Networking Gear & Setup Details

Unifi UDM pro with all unifi switches

Connected Audio Devices

PS directstream dac connected to Mcintosh preamp and Mcintosh 1.25 kw mono amps

Number of Tracks in Library


Description of Issue

Unable to connect with nucleus. I have given it a fixed ip. In the help section and type in the ip it does not discover it. This happened once before but corrected itself. I tried to connect it to the monitor to see if it was getting an ip but nothing shows up on the monitor.
In between when it does work it works fine.
Thanks ,

Hey @Rajiv_Shah,

If you haven’t yet, please see if you can connect to your Nucleus via the Web UI. Here is more info on how to do this.

If possible, please share a screenshot of what your web UI looks like. This can point us in the right direction for next steps :+1:

Hi! I tried that but the app can not connect to the Nucleus ,so unable to get to the web interface. I have given a fixed ip to the Nucleus and am not able to see it in the list of devices on my network and consequently unable to ping it.
Many thanks,

Hey @Rajiv_Shah,

To confirm, have you tried accessing the Web UI via typing the IP address of your Nucleus into a browser? If your Nucleus is online, its IP will show in your router software. That’s what you enter into your browser to get to the web interface.

You can also normally try http://nucleus.local/ as well from a mac, or just http://nucleus/ from a windows machine.

Let me know if any of the above works

Hi! I tried via browser but it did not find nucleus

Hey @Rajiv_Shah,

Got it. Thanks for letting me know. Please check your dns settings on your router and try including your router/gateway address as well as or

If possible, are you able to try using your router’s DHCP server to reserve the address, and not use a static address on the device?

Another good test is to use a USB to Ethernet adapter and plug it directly into your router from your Nucleus.

And lastly, If you haven’t yet, please give your router a hard reboot as well.

It starte to work after I removed the fixed IP and connected it directly to the router

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.