Unable to connect with QNAP Server

Core Machine (Operating system/System info/Roon build number)

Mac OSX Catalina

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Naim ND5 XS fed by QNAP server

Description Of Issue

Having studied your FAQs and look at your community forum, I am having great difficulty in incorporating the music I store on my QNAP server in Roon.

I have tried following your FAQ article here: https://help.roonlabs.com/portal/en/kb/articles/faq-how-do-i-create-a-shared-folder-on-mac-and-add-it-as-a-watched-folder-in-roon

…but to no avail.

Can you help? fyi I currently user the server with my Naim App connected to my Naim ND5 XS device.

BTW I was going to attach a screen print but I can’t see how to do this…

Hello @Geoff_Rowland ,

The media in this case is stored on the QNAP, correct?
If so, please use these guides instead:

Well I’ve read these two articles and tried to follow them…I am totally confused. You sent me 2 articles so I assume I follow the instructions for the first and then the second?
In answer to your question, yes the media is stored on the QNAP.
I have tried following the instructions without success - have you a video tutorial? Or is there any personal one-to-one guidance, e.g. remote access to my computer?

No reply to my previous message 6 days ago - anyone there??

Hi @Geoff_Rowland

Apologies for the delay, the team’s queue is a bit longer than typical at the moment.

Can you share a screenshot of what you’re entering into Roon? We can help walk you through what changes are needed in order to get things working.

You’ve asked me to share screenshot, as I said on my original post, I can’t see how to attach screenshots?

Take the screenshot then reply just as you have then press the little picture button which will give you a file selection pop up.

As requested here are some of my screenshots -

…and another one:

I thought you were trying to connect to the music on your Nas? That appears to be the name of the Mac.
You need to put the name of the Nas in.

I am - I’ve been trying to follow the instruction articles given to me from Roon’s support pages

So, you are typing this is in on the Mac but you want to see the NAS so you have to put in the NAS name. You seem to be typo g in the name of the Mac.
So nas15b6 etc.

Hello @Geoff_Rowland,

Thanks for sharing those screenshots and for your patience while your case has reached out queue again!

In this screenshot, it looks like you are trying to access a shared folder on your Mac, which you have to set up proper sharing for. The guide which you originally posted provides the proper steps for this:

You you need to ensure you have the correct permissions and that you are using the same login as listed in the Mac Security center:

If this still does not work, I would try to add your NAS directly into Roon, instead of using it as a shared drive.

Please keep in mind that Roon does not support AFP shares, so you’ll want to make sure you have SMBv3 enabled in your QNAP settings if you wish to add it directly to Roon. If you do, the path would look something like this: smb://IP OF QNAP/FOLDER NAME and then using the credentials you configured in the QNAP Web Interface.

Hope this helps, but let us know if you have further questions!

Well, you really couldn’t make this up - I had apparent success the other day by connecting directly with the ip address of the NAS - Roon added 10,000 odd tracks! - then this morning I have this! :frowning_face:

Is your Nas still on the same IP address?

Hi Ged, well strangely enough it’s not according to my NAS software, which begs the question why has it changed?

should it really have two directory levels of iTunes music?
Can it not find it because it really doesn’t exist?
Personally I would connect by name not IP address.

Hi @Geoff_Rowland ,

I would check your router web interface to see if you have the option to set up Reserved IP, that way the IP of the NAS will stay the same when the IP address expires (usually every 24 hours).

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.