Unable to find my audio device [Solved - SD Card on Core]

Recently been unable to find my audio device in Roon. I am running the core on a 64 bit PC, music files on a Rockstor HD directly connected to the PC (no problems there), DAC is a NAD C390DD connected to a Musica Pristina A Capella as the music player via USB. DAC is hardline connected to my router via ethernet, that port is green so I don’t think there is any problem there. When I go to the audio settings in Roon, nothing is found connected to the internet. I am baffled and suffering in silence. Any help is appreciated. Ron

Hello @Ronald_Gibson,

Thanks for contacting support, I’d be happy to assist here. Can you please try rebooting your Core, DAC and any Networking gear you have as a first troubleshooting step? Do any of your devices show up in Audio settings (including system output)? Can you please post a screenshot of your Roon Settings -> Audio tab? Please let me know when possible.


I have already rebooted everything, no change.

Try as a test turning off your. Firewall on the pc

turning off all security firewalls does not help

Hello @Ronald_Gibson,

I have a few other suggestions here:

  • Do you have any other networking devices that are not appearing under “Networked” while they should? This does seem like there is some kind of firewall blocking access for Roon.

  • What is the model/manufacturer of your router and any switches/range extenders/powerline adapters?

  • You mentioned that your DAC is connected to the router via Ethernet, but is the Core connected via Ethernet as well? Can you please try temporarily connecting it via Ethernet to verify if you have the same issue?

  • Is Roon listed as an exception in your Windows Defender settings? You can use these instructions to check

Please let me know if any of the above suggestions help.


I had previously disabled all firewalls to no avail. my system router is a AT&T 5268AC, my DAC is connected only to my Musica Pristina A Capella music player (roon ready) via USB, and the music player is connected to the router via Cat5 cable. Music player communicates with the Roon core wirelessly, in fact all devices connect to the PC wirelessly, with the exception of my music files on a remote hard drive connected to the PC via USB. Roon does play correctly to the PC internal speakers, meaning that the music player is out of the loop. I did go into Windows Defender Firewall, and discovered that Roon was not listed. I added Roon and Roon.exe as allowable apps thru the firewall, both on public and private, still no communication with the music player. No other adapters that you mentioned are used. Could it be the music play at fault?

Hello @Ronald_Gibson,

Do you by any chance have any Antivirus Software installed on the computer? I believe that either your AV is blocking the communication or RAATserver ended up in a strange state. To test the latter theory, I would like to “refresh” your RAATServer instance. Please use the instructions below to do so:

  • Before doing anything below, please make a Backup of your Roon Database
  • Navigate to your Roon’s Database Location: https://kb.roonlabs.com/Database_Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

The database location that shows RAATServer folder should look something like this:

Please let me know if the above troubleshooting step helps resolve the issue.


I have two anti-virus programs installed…ESET NOD 32 and Malwarebits. I disabled both and renamed the RAATFolder as RAATFolder_old as directed. Re-launched Roon and I still can only play music to the PC running the Roon Core. Looking in settings/audio/networked there are no devices listed as found on my network.

Hello @Ronald_Gibson,

Thank you for providing that information for me. I have a few other questions/suggestions:

  • Do you by any chance have any other networking devices that are not showing up under networking when they are supposed to? For example, Chromecast or Apple TVs?

  • You mentioned that you disabled ESET NOD32 and Malwarebytes, but do they have a firewall setting that was possibly not disabled?

  • If you have another computer around the house, can you please try installing Roon on it and verify if the same issue occurs? If it occurs on the other computer, we have a good data point as to examine the network setup further, but if it does not then we can take a closer look at the current Core. I would also make a Backup of your database before switching Cores.

Please let me know your findings when possible.


A post was split to a new topic: No Networked Audio Devices Found

Update on my problem, now solved. It turns out the problem was not anything Roon software related (for the most part) but rather the MicroSD card in my Linux-based music player that went bad. That card held all of the OS data, and it lost the ability to find my network. Once the card was replaced with a new one (with software pre-loaded) everything works fine. At first I thought it was Roon related, and went thru all of the suggestions given here, to no avail, that is when I suspected the hardware had issues. I sent the A Capella player back to Musica Pristina and they diagnosed the problem quickly, and repaired it for free (plus shipping). Great music player and great company to work with, highly recommended.

1 Like

Great to hear that you narrowed it down to the SD Card @Ronald_Gibson! Thanks again for contacting support and hope you have a great day!

– Noris

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.