Unable to find Roon Core on Synology NAS from MacOS client

Hello @support

I just started my free trial. Installed Roon Server on my Synology 918+ NAS. It shows as running. The shared folder RoonServer seems to be populated.

Installed Roon Client on MacBook, macOS 10.13.6, and opened it. It started looking for Roon Core, and just keeps looking. It’s been 20 min already, and it is still looking. I clicked “help” and provided the NAS IP hoping it’ll help. It did not.

NAS is on the same network as my MacBook Pro. I can reach NAS from the mac in many different ways, including via the browser, mounting it as a network drive, ssh, etc. with no trouble at all.

Also downloaded Roon Remote on my iPhone 7 Plus. Same problem, it starts looking for Core and just keeps looking.

Please advise.


Roon Client just found the Server! It took well over 30 min. Hope it’s normal.

I’ve pointed the server to the music library and it is now adding the music to the server.

Apologies for false alarm.

Btw, Roon Remote on my iPhone is still looking for the Core, but now I’m guessing it just needs time.

Hey there, @xred,

Thanks for reaching out, and I’m glad to hear that the MacBook is connecting now!

I was hoping you could please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Have you tried rebooting the Core machine, networking hardware, and the iPhone remote since getting things set up?


Hi, @dylan. Just rebooted the router and NAS, and now neither the Mac or the iPhone are able to find the Core. (I made sure Core is running on the NAS of course after the restart.)

Here is how my network is configured. Let me know if you need more detail.

  • the internet router is connected to the 1Gb switch
  • one of the ports on the switch connects to one of the the Google Wifi access points, which in-turn connects via both the ethernet cable and the wifi to the Mac.
  • the other switch port is connected via the ethernet cable to the NAS

That’s pretty much it.

Again, I have no issues connecting my Mac to the NAS in multiple ways by using the local LAN IP address.

Hey @xred,

What kind of switch is in use here? Is it a managed switch? Also, what is the main router being used here?

There are a few points here where the remote connection may be experiencing issues (the router, the switch, the Google WiFi connection), so I’d like to recommend a test that should provide some great information here.

If you disable the Google WiFi access points, and connect the Core machine directly to the main router, do you notice any change in behavior here? If things work in this simplified setup (Router -> Core & Remote), then let’s try adding in the switch (Router -> Switch & Remote -> Core).

This type of test will let us know exactly where things are having an issue so we know where to focus our troubleshooting.


The switch is a simple un-managed TP-Link TL-SG105, 5-port.

So, let me understand, for the first test, are you asking to connect Core to the Internet router and Mac to the Internet router, bypassing the access point?

Hey @xred,

Yes, this test will allow us to test things in the simplest networking configuration possible here, which reduces the number of places where an issue may occur. If things work in this configuration, then we know the access point or the switch may be causing an issue here.


ok, when I connect internet router to the switch, one switch port to core and another switch port to the Mac, Client comes up immediately.

So, it seems Google Wifi access point is the issue. Which is strange because everything else works just fine with it.

I need to have NAS in front of Google access point in order to be able to access it from outside. Everything else is behind Google access point and interconnecting wirelessly.

This also explains why I can’t connect the iPhone to the Core. The iPhone is connected to wi-fi and going through the Google access point.

Both Client (Mac) and the Core (NAS) are on the local 192.168.x.x network, but different subnets. All communication is opened between the two, and it seems that if I could only point the Client (Control and Remote) to the NAS IP (or at least the subnet it is on), it would find it and connect right away.

Of course, if it has to search cold across all possible IPs on 192.168.x.x network, it’ll take a while. I feel that’s why it is taking so long. Btw, earlier it did connect once - perhaps by chance.

Please provide the ability to specify the NAS IP, unless you can think of another way to solve this.

Thanks for the update here, @xred!

Have you tried putting your Google WiFi access point in bridge mode? If not, give that a try and let us know if there is any difference here!


Hi, @dylan. I’ve researched that. First of all Google does not recommend a double NAT. There are also other issues with putting it in the bridge mode. Here is what I got from Google Support:

Does Google Wifi support Bridge mode?

Yes, but it will only work if you’re using a single Wifi point. If you’re creating a mesh network with multiple Wifi points, your Primary Wifi point cannot be in Bridge mode. This is because the Primary Wifi point needs to do special things to control settings and communication within your Wi-Fi network. If it’s in bridge mode, you’ll lose some of Google Wifi’s key features.

I have 3 Google WiFi access points working in mesh mode.


If the way Google Wifi is working gives you 2 different network IP ranges then its not going to fly as far as I can see.

It’s not that Google Wifi gives two different subnets, it only creates one. I have a cable modem in front of it, that has an integrated router. The router is connected to Google WiFi access point on one port, and NAS on the other. The router creates a subnet, say 192.168.1.x, and anything connected directly to it (in this case the NAS) is on that subnet. Then the Google access point, being a router as well, creates its own subnet, say 192.168.40.x, so anything behind it is on that subnet, e.g.,, etc. The two subnets are interconnected; I have no problem with devices behind the Google access point talking to NAS, and NAS talking back to those devices.

Roon, however has a problem with that setup. But it should not. It should allow devices to be on different subnets within the LAN, and as long as one provides the IP, clients should be able to discover Core and Core talk back to the devices.

When I put NAS behind Google access point, which essentially placed it on the same subnet as my other devices, everything worked. That is how I tested Roon. And I loved what I saw. I think Roon is an awesome piece of software, and I was seriously considering signing up for it.

Problem is I can not leave my network topology that way. I need NAS behind the cable modem, so I can access it from outside. If I place it behind Google access point, in order to access it from outside, I must configure access point to double NAT, which Google strongly advises against.

So I’m stuck.

I appreciate the info here, @xred!

Unfortunately, in order for Roon to work how you’d like, you’ll need to have your Core machine and your remotes on the same subnet. Since you can’t use bridge mode on the Google WiFi devices, there are still a couple of options available to you.

You can use a different Core machine that is connected to the Google WiFi devices, or you could potentially try to change things so only the Google WiFi devices are in use and all of the devices exist on that same subnet. Ultimately, your remote devices will need to be on the same subnet as the Core and once they things should work for you.

I’m sorry I don’t have better news for you about the current network setup, Felix, but I’m confident that once the Core is on the same subnet as your remotes you’ll love your experience with Roon.

Kind regards,

Hi, @dylan. Thank you for reply. Unfortunately buying a separate device for Roon to be installed behind my Goole WiFi is not something I planned or allocated the budget for. I do not have a stationary computer, my main and only machine is MacBook Pro, which I carry with me.

NAS is perfect for this, I strongly encourage you folks to support multiple subnets on a LAN. Restricting everything to a single subnet is a limitation that, in my opinion, should be addressed.

Meanwhile, I’ll have to cancel the subscription. I really, really hate to do that, but I have no choice, I’m afraid. The way the software works right now is just unusable for me.

If this ever gets resolved, please let me know, I’d be more than happy to re-evaluate.

The solution is to attach Core device (NAS in my case) to both networks, and it’s just so happens that my Synology 918+ has two ethernet ports. Originally I had them bound, so, I’ve separated them, and connected one interface to the cable modem/router and the other to the Google WiFi access point.

Now NAS can be accessed from either network. Problem solved.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.