Unable to get 7" RPi display to show "Now Playing"

I have the RPi “official” 7" touch screen connected to my RPi 3B+. The screen functions, but doesn’t show the Now Playing screen. If I go to the Ropiee setup page for it, I think I’m supposed to see a tab for setting brightness, etc - I don’t see anything like that.

I followed this thread in troubleshooting my situation:

I see the exact same issue that Gavin had. I see the linux text but, no Ropiee display. However running the pacman commands that Gavin ran to resolve his issue hasn’t worked for me.
pacman -Syu double-conversion
pacman -Syu ropiee-touchui

Those ran successfully, but didn’t change anything.

One point is I am not seeing the undervoltage warnings that Gavin saw, as I’m using a 5A power supply.

I’ve rebooted both the server and the RPi several times. At this point I’m stuck as to what else I could try?
This is all I see:

Hello Thomas,

I presume this is a brand new RoPieee install, eg the initial install occurred with the display connected? (This is when the display is detected and the software installed.)

Yes, it’s a new install. You know, I’m not sure if I had the display on at the start. Does it matter?

Yes it does matter…I would reflash the image and restart with the display connected and the correct wired to pio pins too.


Screen needs to be enabled during installation otherwise it is not recognized. This can easily be checked in the webinterface if there’s a display tab or not.

Furthermore an advice (which you can ignore of course :wink: ) : RoPieee is not a ‘regular distro’. So logging into it and running all kinds of stuff is not recommended.


Thanks wizardofoz. Reflashing with the screen connected did the trick.


What is that case you are using? Link please

It’s called the SmartPi Touch case - $25. I highly recommend it.

Amazon page

Thanks for that … * Not compatible with the Raspberry Pi 4 is a bit of a show stopper for me if I need a need a new Pi 4 but might be OK for others.

I would also like to have the HAT fully enclosed as per my Element 14 case.

nice to have adjustable angle placementment

Yeah, I would like to find such a case also.

This particular one’s strong point is the adjustable angle, where you can adjust the tension.

RS Online and Farnell/Element14 both have Pi display cases that can hide a hat - some will need mods however for things like speaker connections or BNC/RCA outputs. at this point tho most are not Pi 4 ready.

FLIRC have some really nice options but with no hat or display - I use these for standalone Roon Bridge setups networked USB converter with Ropieee.

Sometimes it better to have the display and the endpoint separated due to listening verses seeing what’s playing distances

Well, I kind’a blew it here. I had the display working and everything was good. However, I noticed when playing DSD files I was getting a crackling sound. So, I re-imaged the SD card and started over. Good news is that fixed the crackling with DSD. Bad news is no matter what I’ve tried I can’t get the 7" display to show the Now Playing screen again. I’m stuck at the “Zone Not Found” message on the display.

It asks:
Is the DAC on? - YES and connected
Remote Control Ext enabled? - YES and shows the IP address of the RPi I’m using.
Correct Zone Configured in RoPieee? - I have “Sprout” set in the Remote Control Tab. I have “Sprout” set as the zone name for the RPi ALSA USB2.0 connection to the Sprout DAC.

When I go to the RPi’s RoPiee page I don’t see the “Display” tab. ALso, I seem to recall that if I go to Roon’s Settings\Displays I should see it there also - but I don’t.

Since the RPi also has a HiFiBerry Digi hat on it I have tried the above steps with the USB/Sprout zone disabled and just the HiFiBerry enabled to see if this was an issue with having to use the assigned hat as the correct zone. But, no luck there either.

I grabbed another SD card, imaged it and went through the installation process again - same issue.

Maybe, there’s a special order in which I’m supposed to config the device that I’m missing?

No there isn’t.

The fact that you get a ‘Zone not found’ message means that at least the screen is recognized.

Can you send me feedback?

Thanks. I just sent it - c4e3611c782ab673

Have you checked and restarted the Ropieee extension in Roon or restarted Roon?

Oh, many, many times. I also rebooted the Roon server a few times, and the RPi.
It plays fine now with DSD files, just can’t get the display back. It’s sitting there now in clock mode. But, it just won’t connect to the zone for some reason.

Here are some screenshots of my settings - maybe I’m missing something?


This is so weird. I don’t understand why you have these problems…

Anyways: the thing is broken. It installed all parts (hence the ‘zone not found’ message on the screen), but for the rest it did not register properly (which I really don’t get) that this is a unit with a touchscreen.

Hence no tab in the web ui, hence no proper configuration, hence the ‘no zone’ message.

I need to dig further in the logs trying to find out what the h* is going on.

Ok Thomas,

I think I have a clue. Timing issue.

For now you can fix it by logging in, opening the file


and change the variable


to 1

so it looks like:


save and reboot.

1 Like

Thanks a ton! That worked :+1: Though I had to go back and lookup the vi text editor commands :yum:

Yeah, I don’t know what happened here. I used the same file to image that I was successful with the other day. Same RPi, same display, but for some reason even after 2 SD cards and 2 re-imaging attempts it didn’t want to work. You can be sure I’m going to backup this imaged SD card.