Unable to get ARC to work

Roon Core Machine

Roon Nucleus

Networking Gear & Setup Details

Netgear Orbi RBR750 with ethernet directly to Roon Nucleus

Connected Audio Devices

Number of Tracks in Library


Description of Issue

Have checked UpnP is on
Have tried (to the best of my ability) to setup port forwarding
Went round ethernet switch and connected Roon Nucleus directly to Router
Roon endpoints Macbook Pro 14in 2022 Apple Silicon and iPhone 14pro

Keep getting the error below from Settings/Roon Arc

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“119.aaa.bbb.ccc”,“actual_external_ipv6”:“2403:5806:d227:0:56b2:3ff:fef6:aa9a”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“server_ip”:“”,“found_natpmp”:true},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">501ActionFailed</s:Fault></s:Body></s:Envelope>”}

Did you create a manual port forwarding rule for ARC in addition to having UPnP enabled? Don’t, some routers don’t deal well with this and it may be the cause for your error. Do one or the other and see how that goes.

(UPnP is precisely the router service that allows apps to open ports, so that you don’t have to create manual rules. Doing both confuses some routers although it shouldn’t)

Welcome to the forum!

Thank you @Suedkiez for that.

I have now unticked UPnP and re started.

I have set a static IP for the nucleus and checked on both the nucleus and router that IP is the same. Set port forwarding for that IP address and restarted everything.

Error code is now

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“119.aaa.bbb.ccc”,“actual_external_ipv6”:“2403:5806:d227:0:56b2:3ff:fef6:aa9a”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}


Ok, UPnP has clearly stopped being available. But did you set up a manual port forwarding rule?

Earlier it looked like you might have, and as if the router might have been confused by having manual rules and UPnP. Now that UPnP is off, it looks like there is no manual rule after all.

Thanks. As far as I can tell I have set an active port forwarding rule saved for the IP of the nucleus. (Not sure how to post a screenshot of the router here.)

Click this button

Or drag an image into the box or paste with Cmd+V from the clipboard

Thanks, appreciate your time helping me. Here is a screenshot from the router.

And here is one with the detail of the rule.

Looks legit, assuming that the IP and the port are the same as shown in the Roon ARC settings. (I’m aesthetically offended by the rule being called FTP, but it’s just a name :slightly_smiling_face:)

I’m a bit at a loss here

Do you have an ISP modem in addition to the Orbi or is the Orbi directly connected to the internet?

The FTP name was prepopulated by the Orbi.

IP and ports are the same.

I’m in Australia and we have two layers of ISP - wholesale and retail - the wholesale is govt run cal NBN which in my case provides fibre to the premises (including their hardware which is a modem only) and then the retail ISP lets you choose their router or bring your own. I have the Orbi mesh.

I might call the retail iSP and see if they can help.

@Aidan_Keough, to what hardware device does your Orbi connect to the NBN network? Is it a Nokia ONT or another type of device?

Also, Roon does not always play well using an IPv6 addressing scheme (you have an IPv6 address of 2403:5806:d227:0:56b2:3ff:fef6:aa9a). Is there a way to deactivate IPv6 for your account, or set up a dual or passthrouugh capability with your IPv4 address?

@Robert_F thanks. Not sure what the device is… it is provided and installed by the NBNCo. Image below.

The orbi router has a section in settings on IPv6 but nothing about ipv4.

Purple tick = Solved


Quick call to ISP Aussie Broadband and worked out that they use CG-NAT as they have run out of IPv4 addresses and haven’t deployed IPv6 yet. Confirmed this will stop port-forwarding (game servers, music streaming and remote access etc) from working.

Switched over to static IP for ORBI router for $5 a month and gave nucleus a static IP network address and all works great now.

Just have to buy a DAP that I can load Roon ARC onto (to replace my AK SR25mkii - great sound but terrible connectivity incl. no ARC spk) and I’ll be all set on the road.

Thanks a lot to @Suedkiez and @Robert_F for your help which educated me and steered me in the right direction, cheers. :+1:


@Aidan_Keough, glad it is sorted for you with a static IP!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.