Unable to get logged in after backup restore

Hello! I had been using Audiolinux but the machine it’s on has trouble mounting the drive where my music is stored so I’m moving the roon core. I have good backups and when I restore the backup to the new core (following the Migration article), it restarts the Roon interface, I log in with my email and it just sits there at the Roon loading icon for hours. I’ve deleted Roon core and set it up again, restored the database, logged in and get the same results. Any suggestions on what I might do differently?


Hi @Jamie_Dewoody,

Thank you for the report, and I’m sorry to hear you’re experiencing login troubles. Just to clarify, since you mentioned a database restore; did you fully refresh the database by taking the following steps? This will clear out any cached settings/system files, etc. Since you’ve already migrated, I’d take this step on both the new Core and the old Core (once you have a backup saved in a separate location), for due diligence, before installing Roon on the new Core and restoring your backup.

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” and “RAATServer”
  • Rename “Roon” to “Roon_old” and “RAATServer” to “RAATServer_old”
  • Reinstall Roon from our Downloads Page

Thank you for the response. I did that but now it’s just stuck in a choose your core loop

The main thing is I don’t want to lose my playlists. Is there a way to set up a new core and restore only those?

I should also mention that the server core names are different. I don’t know if that’s the issue but wanted to add this info.

Why do you have all those ‘Repository’ waiting for connection? Is that your Core name? What kind of OS is your new Core on?

No, on a Restore it’s all or nothing.

Shouldn’t matter as long as it’s the same Roon account.

Thanks for the reply. Yes, that’s the core name. That’s the “select the core” loop I mentioned. The core is Linux.

I only have one Roon account so that answers that.

Ok, now I’ve set up a NUC with Rock, install works but I’ve tried to restore 2 backups that are supposed to be good and it just sits there

Please help, this is getting a bit frustrating. Thanks.

If you don’t do a Restore, but let ROCK come up with a fresh database, does it connect? Just as an experiment to see if your ROCK install is good.

Yeah, the ROCK install comes up fine. The Linux Roon core did as well.

Weird. It sounds like your Backup is no good. That shouldn’t be happening any more.

I guess that you’ve tried all other Backups and got the same result?

Tagging @support. Hope they have a better answer. Backup corruption was supposed to have been fixed, but maybe not.

Good luck.

Oh yeah, two other things. Can you bring up your old Core and take a fresh Backup or have you tried bringing up ROCK with old Core turned off? Shouldn’t make any differences, but straws grasped as it were.

I’ve tried the 2 latest, I’m about to try a couple more. Any restore in the last month is better than starting over.

The old core is turned off but will still come up. Problem is, since it can’t mount the drive that was connected locally with music, I’m assuming another backup would be unusable, because it shows a lot of songs missing.

Thanks for the input and wishing me luck. I need it.

1 Like

I’ve now tried 4 backups, all with the same result. This is really making me question the validity of Roon’s backup system.

One of my playlists has over 3200 songs in it and it looks like I’m starting from scratch. I cannot begin to tell you how unhappy I am about this.

Are you logging in to your new Roon Core first and then trying to restore a Backup?

Because you should restore a backup from the login screen first, not login and then restore…

Correct, I was restoring prior to login. Everything I’ve done has been according to Roon’s KBs. It’s not my first time moving and restoring the database.

I’ve moved Roon and then Restored later, with no ill effects.


@Jamie_Dewoody, since you have nothing to .lose at this point, log in to your Core and then try a Restore from Settins==>Backups. :slightly_smiling_face:

I’ve tried that as well, just for kicks. Cup of fail there too :grin:


Let’s see what @support says, but it looks (to me anyway) that your Backups (all of them?) are no good. In the past Backup has had logic problems. It’s always been Roon’s neglected child.

Very disturbing for all of us who conscientiously take Backups.

I’m afraid you’re right. Thanks again for trying to help.

For those of us who are normally comfortable with utilizing backups, this is a bit of a wake up call. Once I go through the exhausting process of rebuilding all of my playlists, I’ll start exporting them in addition to the backups, since this process is such a PITA and this has taken away my faith in relying on backups.

I’d lose my job in IT if this was how our backups worked.