Unable to get wifi to work with Pi3


(Paul Armstrong) #1

Hello

I’ve been running Roon through Ropieee on a Pi3 (Audiophonics RaspDIGI LTE LVDS) over ethernet - it works fine, but I have problems with network noise over the LAN. So, I wanted to try wifi.

I configured wifi as suggested in the guides & all setting in Ropieee seem correct, but with ethernet cable not attached & re-booted, the Pi3 cannot be seen via wifi in Roon.

Core Machine (Operating system/System info/Roon build number)

Ropiee on Audiophonics RaspDIGI LTE LVDS. Ropiee version 248-1. Roon version 1.6 - build 401.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Trying to make wi-fi work. Works okay via ethernet.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

HDMI to DAC from RaspDIGI.

Thanks
Paul


#2

Have you followed this guide?
https://kb.roonlabs.com/Networking_Best_Practices

Make sure your setup also meets this requirement:

Network Setup It’s important to be sure both computers are on the same network, and have the same network settings. The best way to confirm this is to check your IP address and network settings.

When you find your network settings for both computers, you’ll to confirm:

  • Both are on the same IP network (ie 192.168.1 .104 and 192.168.1 .106)
  • Both have the same netmask (this often looks like 255.255.255.0 )

To find your network settings on Windows, type “Network and Sharing Center” into the Start Menu. Then, click on your connection (either WiFi or ethernet), then select Details.

To find your network settings on OSX, open System Preferences from the Apple menu, then click Network. Click Advanced to find your IP address and netmask.


(Paul Armstrong) #3

Thanks @BlackJack - yeah, checked the IP addresses and netmask (for my core = Dell XPS15) and as set in the settings for the Ropieee for the Audiophonics streamer. Nothing doing, as yet. I’m not even sure the streamer is being seen by the network (over wi-fi).


#4

Then you should check that. Login to your router or access point. They normally have ways to show connected clients. If it’s not there, take a look at the logs for connection errors that might belong to the RPi.


(Paul Armstrong) #5

Thanks - apologies, I’m a bit of a novice user, but here goes. I managed to see it on the router - as a wired connection (ethernet), and then for a brief period as wireless - at that time, Roon was trying to configuring it in its Audio settings area. However, it was booted off - by the router? by Roon? Not sure how I can tell.


#6

How could that be?


(Paul Armstrong) #7

Ah, sorry, I’m probably confusing the issue. I re-connected the ethernet, just so i could see the Pi3 in the router. Once i’d done that, I disconnected ethernet & let it connect with wifi, which it did, and then disappeared.

I’ve since just reconnected. My router tells me it can see the Pi, but Roon doesn’t. After a couple of minutes of it being connected to the router (but not seen by Roon), it disappears from the router again.


#8

I^m out of ideas for the moment. I’m sure some more experienced Ropieeee users can come up with further knowledge.


(Geoff Coupe) #9

Flagging @spockfish - Harry is the creator of Ropieee - he may be able to suggest something…


(Paul Armstrong) #10

Thanks so much @BlackJack & @Geoff_Coupe. It is a mystery…

Cheers


(Harry ten Berge) #11

Hi @Paul_Armstrong,

Can you start the unit with network cable connected?
Then go to RoPieee’s webpage and hit the ‘send feedback’ button on the advanced tab.

I can then have a look what’s going on…


(Paul Armstrong) #12

Hi Harry

Thanks so much for this. The weirdest thing - I left the streamer etc overnight (I’m down in Australia) and today, it connects into wi-fi (weakly, so I need to improve the networking), but it is there. However, now when cabled over ethernet, I can’t get into the Ropieee page to access data about the unit & what it is doing.

So, I’ll see if I can keep using the wi-fi connection - and if there are any issues, I’ll try again to send some feedback via the page. Hopefully, however, a night to sleep on it has brought the Pi3 to its senses.

Cheers
Paul


(Mr Fix It ) #13

Maybe plug it in closer to the AP for a better signal.