Unable to import iTunes on a Mac network share

Core Machine (Operating system/System info/Roon build number)

MacOS Catalina vn 10.15.5

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Virgin Media router, using Ethernet over mains to connect to another room (See attachment Hifisetup.jpg)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Devialet Expert system connected via ethernet to main router. Zoneripper connected via ethernet to main router. Devialet Phantom and Linn Sneaky connected via ethernet over mains in another room. MacBook Pro with iTunes library running Roon Core connected via Wi-Fi, and two iPads running Roon over Wi-Fi.

Description Of Issue

I am unable to add a second MacBook Pro with music on it. In the Roon core, I go to Settings - Storage - Add Folder - Add Network Share and in the Network Share Location box I add the relevant details and I get an error message, “Could not connect to share: Unauthorized” - see attachment entitled Screenshot 2. On the MacBook in question, you will see that I have set up File sharing (attachment entitled Screenshot 3) and that I have also enabled sharing files via SMB (attachment entitled Screenshot 4)

Please can you advise what else I should do. I have carefully studied your knowledge base on how to create a shared folder and add it as a watched folder in Roon, have followed all the steps, yet I get the Unauthorized message. The Mac I am trying to connect to does not have a firewall connected or anything else that I am aware of that would prevent Roon from accessing it. I am at a loss to now what to do next!
Any help would be gratefully appreciated.

Many thanks.

Kind regards
John Buchan

Hi John,

Try using the IP instead of the hostname and see if that works.


Hello @John_Buchan, Rugby is correct here. Let me know if that helps!

Hi, thanks for the suggestion, but I get a different error if I use the IP address. This time, it says, “There was an unexpected error: Invalid Network Path” - see screenshot

The error comes up immediately as soon as I click on Add Network Share.

When I used smb://Johns-MacBook-Pro.local/Users/jb/Music in the network share location box, when I clicked on Add Network Share, the animated Roon logo appeared for a few seconds along with “Adding. . .” suggesting that it had found the laptop but was unable to get access. The startup disk on the Mac to be connected is called John Buchan and the password I use is definitely correct, so I am stumped! I suspect this is either a Mac thing whereby I need to unlock something else in order to allow remote access (I do have FileVault enabled, but it says that using my admin username and password allows things to be read ok), or there is a specific string I need to use in Roon’s Add Network Share facility that will allow access ok. Unfortunately, the error messages I have received aren’t granular enough to know what I need to do. “Unauthorized” could mean a multitude of things!

I am really struggling with this, so would appreciate any and all help.
Thanks and regards

After the IP number you need the share name.

Hi John,

Also, when you clicked the + sign to add the share in System Preferences > Sharing, you already created the path, so don’t include the path when adding the Network Share Location. In other words, you just need to use Music as the share.

So use:


Cheers, Greg

Thanks all for your suggestions. I tried both and on each occasion I got the, “Could not connect to share: Unauthorized” message. So I started to work through the permutations and combinations of the hostname and IP address with and without folder names, and one one occasion I forgot to include my Username and Password - and it worked! I have since discovered that using smb://Johns-MacBook-Pro.local/Music OR smb:// in the network share location box WITHOUT supplying a username & password works a treat. I suspect I would have taken much longer to arrive here without your suggestions, so thank you all for your assistance - very much appreciated.


Hello @John_Buchan, glad to hear you got it working! Let us know if you need further assistance.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.