Unable to Log into ROCK, Brand New Hardware and Install


I built a NUC ROCK tonight to install Roon OS as my core machine but cannot log into it no matter what I do. It is driving me crazy. Maybe I’m just missing something simple?

Core Machine: Intel NUC8i7BEH, Samsung EVO980, 16GB RAM, Up to date BIOS BECFL357.86A (Version 0083) Set BIOS as outlined in guide, installed using roonbox-linuxx64-nuc3-usb-factoryreset.img.gz tonight (10/19/20) with Firmware 1.0 build 227 stable.

Network Details: Netgear Orbi RBR50 (with the latest firmware V2.7.0.70), with a CAT8 cable hardwired to the NUC directly from the router (also tried CAT5, CAT5e, and CAT6 to see if it was an odd cable issue, no luck).

The ROCK loads up on the network and I can access it via the IP address in a browser. Whenever I open Roon on my computer, phone, etc. and select “Roon Optimized Core Kit” and attempt to log into it, I cannot log in and instead get the network error:
“Network error: Please check your internet connection”

The account does work because if I select my PC as the Core it can log in just fine. The ROCK always gets that network error.

On the ROCK, I have tried using the DHCP setting and using a Static IP. With the Static IP set in the router, switching back to DHCP on the ROCK does not help either. With a Static IP set, port forwarding UDP port 9003 and TCP ports 9100-9200 does not help. Searching the community for Orbi specific issues, I made sure that “Enable Implicit BEAMFORMING - Boosts WiFi speed, reliability, & range for all mobile devices” is disabled. No dice.

Re-installing and starting from scratch, resetting the network, and powercycling everything did not seem to have any effect.

Is there something simple I am missing?

Thank you for your help!

Still unable to log in despite some additional troubleshooting:
I’ve tried changing the DNS to,,, etc. without success. Reinstalling the OS and resetting the database via the web interface did not help. Renaming “RoonServer” to “RoonServer_old” and then restarting RoonServer in the WebUI did not help.

Sometimes the log returns:
Trace: [broker/accounts] Data updated. AccountStatus=NoAccountConfigured MachineStatus=NeedsAccount UserId=

More often the log returns:
Trace: [push] restarting connection (Connection timed out

I can see the Core as an option in the Roon app on all devices connected to the network and WiFi, and the WebUI works fine…

I’m starting everything from scratch a 3rd time to see if it helps but so far I’m stumped.

What else can I try? Thank you for your help!

Do you still have Roon core running on the PC whilst trying to connect to the NUC Rock core

Is the IP address assigned to ROCK in the same range as your WiFi that remotes run on?

That was a concern of mine initially. The core had only been running on one PC to test it and the account, but it was then stopped and the program was uninstalled. I deleted all folders associated with it and even turned off that PC during some of the troubleshooting. Because the ROCK never logged into the account I was never asked to “Deactivate” or “Unregister” the PC core that was first created. On other devices the PC does not appear as an option to log into, only the ROCK. Thanks for your help!

After installing the Core on a PC and logging into it again I went into settings and used “Disconnect” to get back to the Core selection page. Unfortunately this did not solve the problem. The ROCK still gives a “Network error” and cannot log into the account.

The IP of the ROCK is within the range of everything on the network. I tried making it low on the range, like, and tried putting it above and outside of the range as well. Unfortunately it did not seem to help.


In the end this issue was specific to the Netgear Orbi RBR50 router (but it may apply to others). Everything was correct for IPv4, but the IPv6 IP Address Assignment “Auto Config” setting was preventing the login on the ROCK. Switching to “Use DHCP Server” allows the ROCK to log in!

On the ROCK, a Static IP is set OUTSIDE of the IPv4 DHCP Table range, with a Google DNS.

I hope this helps someone else!


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.