Unable to login to Tidal - Frustrating

Please check what is happening with me in the video. https://share.icloud.com/photos/0eClujhhXJ2CBxBduYXE4Rx0Q

Tried logging out and in again. Tried two laptops and an ipad, nothing is working.

I am able to play the local library just fine, but unable to login to Tidal.

Please help.



A post was merged into an existing topic: Trouble logging in to TIDAL - with new method

Hi @Seif_Maher,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

In some cases we’ve found that there might be a delay with the API when logging in that the team is currently working on investigating. After entering your login information can you wait about 60 seconds before returning to Roon and let us know if that results in any changes?

What browsers are you using on the laptops?

A post was split to a new topic: Trouble logging in to TIDAL : with new method

Hi @Seif_Maher

After telling another user about 5 minutes ago that I hadn’t had any TIDAL login issues I ran into the issue shown in your video but I then touched my iPhone screen to get rid of the TIDAL login pop up screen in Roon and after a second or two it showed me as logged in.

Have you tried this?

Hi @dylan,

Thanks for your reply.

I have my Roon core set up on a Synology NAS, which is connected via ethernet to my network. I have so many remotes that are connected via wifi and ethernet (MacBook, iPad, iPhone,…). The media is stored on one of the hard drives of the NAS.

I tried to login to Tidal through all my remotes, with no success. I use Safari on my iOS and Mac devices.

I did try to wait for 60 seconds before returning to Roon, and it didn’t work.

This setup was working flawlessly for months, but just recently I am having trouble connecting to Tidal.

I hope you can help.

It didn’t work :frowning:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.