Unable to login to Tidal with initial Roon install

Core Machine (Operating system/System info/Roon build number)


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

WiFi - Eero Mesh- working

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Streambox ultra Roon ready device - working

Description Of Issue

I just installed the Roon software on iMac which I designated as the Core. I have a lifetime Roon subscription. I have a confirmed active tidal account and able to log into tidal direct just fine. when trying to add Tidal as service to Roon, I get redirected to a Tidal web page and successfully log in with my credentials -I then get redirected back to Roon, but Roon doesn’t recognize my Tidal login and still displays the box requesting me to log into Tidal. Tried reinstalling Roon, tried rebooting, tried removing Cache file from Roon core file library, tried rebooting modem, router, and ethernet switch, tried to find tidal file under registry file but does not exist. Please help

I am unable to get Roon to allow tidal log in.

This happens every time there is a software upgrade by Roon
Very frustrating, even after version 2.0 was unable to log in to tidal from Roon on my core, a MAC PRO, but did so on the pad. Are there any answers?

Hello @Gary_Weiner, and welcome to the community! Could you please go into “Settings>About” in Roon and send me a screenshot? We made some changes to the TIDAL login process recently and running build 571 is crucial. @Andrew_Matteliano, please check this also.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.