Unable to make manual edits to track/album data [Solved]

My Roon ecosystem consists of an i7 NUC running Roon server on Win10 with the music files on a Synology NAS; for endpoints, my desktop runs Roon, I have an i5 NUC, running ROC and I also have a couple of Oppo -203s.

My problem is that when I try and make manual edits to album or track metadata, such as version etc from my desktop PC I am unable to enter any data. Interestingly, if I make the same manual edit from my iPad remote, the edit is accepted without any problem.

On the PC, when I click on the manual data entry spot it seems like the page instantly refreshes. From the PC I am able to update album art using the add album art button and file selection.

@support, Any help with being able to use the PC to make these entries would be appreciated. Thanks

Hello @john_Winterberg,

Sorry about the slight delay in getting back to you here. We are attempting to reproduce the issue you’re describing on our end and for us to get a better sense of what’s going wrong here, can I please ask for the following?
• Is this affecting just your local music files or files from TIDAL as well?
• Have you updated to Build 323 of the Roon App on both your Computer and the iPad app?
• Can you please provide a screenshot of the edit page on both your Computer and on the iPad?
• Can you let me know which steps you’re taking, and where it’s not working for you?
• Have you tried rebooting your NUC to see if the issue still persists?
Please let me know when possible.


Hello @noris, Thanks for getting back to me on this issue.

I only have local files, I haven’t started a Tidal subscription.
I just updated to Build 323 and I’m seeing slightly different behavior.

In this example, I’m trying to edit the version information. When I mouse click on the blank “edit” entry box, Roon pops-up a keyboard.

I think this is new in version 323. I am able to use the pop-up keyboard and mouse click an entry into the “edit” version entry box.

I am not able to mouse click on the version edit entry box and directly type into the box. Is this intended? This was a bigger problem in version 320 when I was not getting the pop-up keyboard. Typing directly into the data entry box would be preferred.

And yes I have re-booted my entire system from when I just installed Roon version 323.

Thanks again @noris

Hello @John_Winterberg,

The On-Screen Keyboard can be enable/disabled in Settings -> Setup -> Enable On-Screen Keyboard. The On-Screen Keyboard functionality is intended to be used with “headless” devices that do not have keyboards attached to them. Furthermore, I have been trying to reproduce this on my end, but even with the On-Screen Keyboard enabled, I am able to click directly into the “Versions Edit Box” and type with my physical keyboard and it should automatically hide the On-Screen Keyboard once you start typing on the physical one. Can you please try disabling the On-Screen Keyboard and see if that solves the issue you are facing here?


@noris, if I un-select the “Enable On-Screen Keyboard” then I am able to edit with my desktop mouse and keyboard. Thank you.

What is odd is that when I first installed Roon, I did not have this issue and I was able to use my desktop mouse and keyboard. I don’t remember ever selecting the “Enable On-Screen Keyboard” but one day I just started having this issue. Prior to the latest release of Roon 323, I was not getting the on-screen keyboard so I never thought to check for something like this.

Just to confirm, when the “Enable On-Screen Keyboard” is selected, I am unable to use my desktop mouse and keyboard. I am able to click on the edit box but when I try and type anything, I get a rapid refresh and I’m kicked out of the edit. Now that I know about the “Enable On-Screen Keyboard” selector, I’m OK. Hopefully this is a per-remote selection?

Thanks very much for your help.


I’m glad to hear that solved your problem! Yes, the “Enable On-Screen Keyboard” is on a per-remote selection and that saving should be saved in the Roon App based on what remote that you are using. I can’t confirm as to why the screen is flashing with the “On-Screen Keyboard” since I was unable to replicate that issue on my end, it may be related to your graphics drivers on the PC when trying to display the keyboard. I’m going to go ahead mark this thread as [Solved] but if you have any additional issues please don’t hesitate to contact support!


Thanks @noris!

FYI in case it comes up in the future I’m using the On-chip Intel HD Graphics 4600 with the driver.

Best Regards,

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.