Unable to pick audio devices

A few days ago I came to Roon to play some music from my desktop dac and it stated that no audio devices were selected. Going into the “mange audio devices” I pick my dac from the list but it never holds. It also eliminated the naming convention I had for it. Even when I try to rename it won’t stick.
Very odd. I can also not stream from my ipad anymore either.

A few questions, machine type, OS, what is your DAC, how is it connected, is Roon running 24/7 or are you stoping/starting it. If your DAC is disappearing and losing its name, I suspect that is because Roon is losing connection with the DAC and treating when it sees it again as a new DAC and creating a new endpoint profile. Maybe a connection issue.

Dell Studio XPS 435T
Windows 10
Dac: Moon 230HAD connected via USB
Roon runs 24/7 but has shut down without my involvement

It sees all my devices I just can’t pick one to use for playback.

What’s steps are you doing to try and select a play back zone?


Settings>Audio>Enable the DAC. Its says “unnamed” so I type “Desktop” into the field and when I hit enter it reverts back to “unnamed”. It will not save.

What icons do you have on the bottom left of the Roon screen or is there a blue box in the bottom middle saying “Connect audio device” or some such?

Have you tried restarting Roon and rebooting your DAC (I know, I know! bit it’s surprising how often this works!)

Was this working and then stopped or has it never worked?


Roon was working perfectly before this occurred. Yes I tried rebooting Roon and unplugging the DAC and back in and as I said it sees the DAC. It just will not allow me to pick it as an end point. I can stream from one of my Apple TV’s but that it.

No icon on the bottom left, I did have the blur box in the middle but it since has disappeared as it can now see my Network players and I can choose from them. But when I still try to enable to DAC on my desktop nothing happens.

I’m afraid I can’t be any more help then as you seem to be doing everything correctly.

When @mike or @andybob are around, they will be able to help.


Thanks for your time. Appreciate the effort.

Hi Matthew,

Not something I can remember seeing I’m afraid. Let’s drop some flags for @vova and @kevin to investigate. Mike’s currently on holiday (back after weekend) but hopefully something can be found and fixed before then.

As Daniel said, it could be a connection issue. Does a different USB port on the PC or USB cable make a difference ?

I changed ports and like before, it recognizes the DAC but it will not allow me to name it and then select it for playback. Might need someone to take controls on computer so they can see for themselves. Very strange.

Hello @Kimmyrocker,

Apologies for an issue. Is there any other apps running which may control your DAC: ASIO4ALL, JPlay, JRiver or similar to that? – I’d recommend to check the running apps with the Task Manager.


No nothing running like that in the background.

OK, let’s start from the very beginning:

  • Have you tried to restart your XPS machine ?
  • Can you playback to your DAC using other software ? (iTunes, FooBar or any other player? )
  • Can you make a screenshot of audio settings ? (accessible from the small gear on the Audio tab of Settings)

Yes the DAC has been tested and works with other programs. I’ve restarted several times.

As the screen shot shows, it can see the DAC, but it will not allow me to name it so in the end can pick it. Same issue with other Apple tv`s in the house.

Did you try disabling Event Driven Mode to see if that made a difference.

Yes I did. No change.