Unable to play any Tidal song out of Roon

@support Hi, i freshly signed for Roon and set up Roon Rock running on an Intel NUC7i5 with 8GB RAM. I also added my Tidal account.
Unfortunately, i can not play any song from Tidal via Roon.
In all cases, an error message appears:
“This track is not currently available from Tidal”
“Transport: Too many failures. Stopping playback”

All SW is on most recent level. Playing Tidal directly from my MacBook is fine.

What to do? Any suggestions?


Thanks for reaching out, @Jochen_K!

So we can better assist you, may I ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Have you tried power cycling your Core machine and networking hardware since experiencing this behavior?


Hi Dylan

thanks for your reply. Let me add further information as requested:

My Setup:
I am running Roon Rock 1.5 Build 339 64 bit on an Intel NUC7i5BNH.
Endpoints are:

  • Allo USBridge (1.0, build 164 with Dietpi) having a Questyle CMA600i DAC connected
  • Sonos Play 1
  • system out of MacBook Pro 2011 High Sierra

Music is stored on the NUC having separate internal SSD. And i use Tidal Hifi.

Rock and Bridge are connected via Ethernet to a Speedport Router (German Telekom) connected to Internet with 50Mbit.
I am using DHCP for all devices.

Music collection is small with roughly 7.000 tracks (i just set it up yesterday)

The Issue:
Every time i want to run a Tidal track, i receive the error messages, mentioned already above. Even when i press PLAY multiple times, the track doesn’t start playing.

The problem is regardless of the endpoint i select (USBridge, Sonos, internal system output)

I have no problems with internal music files on the NUC’s SSD.

Tidal as desktop app or iPad app is running fine, no problems.

Audio settings (example is for system output):

What else is worth to mention?
I was running Roon Essentials on ELAC Discovery before and had no problems in running Tidal Hifi.

Hey @Jochen_K,

In the past we have seen Google DNS help with similar reports. Can you try using Google DNS and let us know if you notice a change?


Dylan, i am a bit familiar with the network stuff, but not an expert. So could you explain where exactly should i adjust DNS?
-Rock (with change to static ip)?
-Control devices(macbook and ipad)?
-my router?

just the DNS or also Gateway?

Anyway, let me update you on my adjustments and test results:

In my Router:
I adjusted to (prim.) and (sec.). my router doesn’t allow to specify DNS for IPv6, so the standard-DNS settings for IPv6 are still as defined by my Internet-provider.

On Roon Rock:
I adjusted the settings as follows:

On my Macbook:
DNS settings adjusted as follows:04

I rebooted all services (router, rock, macbook browser).

What is the result?

Nothing changed, i am still not able to play any Tidal content.

You might want to change the secondary to which is google’s secondary dns address.

I’m having the same issue today. Might there be something wrong with Tidal’s API?

Thanks Tony, you are right. This was a typo and i will correct it later today. But i do not expect that this will solve the problem.

I ckecked moreorless all threads i could find with similar or same problems. Aside switching to Google DNS and clearance of the cache, i couldn‘t identify anything that solved the problem.
Therefore i will also clear the cache when i am back home. But since my Roon Server was freshyl installed, i also do not expect that the cache will have an impact.

Dylan, are you aware of any further things to do?

Hey @Jochen_K,

Thanks for giving that a try!

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.



i just reproduced the issue at following timestamps:
1:05:00 pm
1:05:37 pm
1:05:49 pm

As you might be located in Brooklyn all timestamps are EDT.


Thanks, @Jochen_K!

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.


Update — The report has been received and passed along to the tech team for analysis.

ok, thanks! good luck…looking forward for feedback and a hopefully you will identify the root cause

Hey @Jochen_K,

The team took a look at the report and have recommended the following:

  • Log out of TIDAL in Roon
  • Reboot the Core machine
  • Log back in to TIDAL

Once you give this a go let me know if there’s any change in behavior here.


No change :disappointed:

I appreciate you giving that a try, @Jochen_K!

The tech team is continuing with their investigation. I’ll be sure to update you as soon as they’ve provided their feedback.


are there any news from the tech team?

Hey @Jochen_K,

Apologies for the delay here. I checked in with the team today, and this is still under investigation by them. I’ll be sure to update you ASAP once they’ve provided their feedback.


Hey @Jochen_K,

I greatly appreciate your patience here while the team has been investigating. I had a chat with them today and wanted to reach out.

Our team has been able to replicate this behavior and will be investigating further and opening a ticket with our development team. While I can’t say for certain when this will be resolved, getting things reproduced in-house is a critical first step, and I will keep this thread up to date as the team passes along feedback and work begins to get this resolved. Thanks again for the report!


of course, being able to reconstruct the behaviour should help to further investigate.
Please let me know in case there is a workaround that is worth to try out…i really miss my Tidal music.