Unable to play FLAC 24B/96 and up on KEF LS60 using Roon. No issues when not using Roon.

Roon Core Machine

I have tried multiple setups, the most powerful machine I have used for the Roon Core performs identically (same issues) as if I use my NAS as Roon Core.

Windows 10
CPU: AMD Ryzen 7 5800H, 8 core, 16 threads, 3.2 Ghz
RAM: 16gb DDR4 3200Mhz
Roon Build: 1182 and 1193 (both experience the same issues)

Networking Gear & Setup Details

Router capable of 1Gbps wired (900+mbit/s down, 700-800+ mbit/s up), 350 Mbps down / 200+ Mbps up 5ghz wifi (tested where speakers are placed)

Speakers are on wifi
Everything else is wired ethernet

Connected Audio Devices

KEF LS60 wireless, connecting using wifi

Number of Tracks in Library


Description of Issue

I am unable to play FLAC files from 24B/96 and up on KEF LS60 using Roon. Usually the track starts randomly stuttering, then it gets worse, and finally stops completely midway. Sometimes the track does not load/play at all and stops / skips to the next track until its a lower bit rate file.
I have tried turning off volume levelling as well and there’s no difference.
I have tried different setups and all have the same issues:
(1) Laptop as Core (specs above), library on the internal NVME SSD, music files on a USB3.0 connected external HDD
(2) Laptop as Core (specs above), library on the internal NVME SSD, music files on NAS (wired Cat 6 connection)
(3) NAS as Core, library on NVME SSD (in the NAS).

I have zero issues playing any of these FLAC files using the KEF app via a UPNP/DLNA media server (all servers work such as Universal Media Server, Plex etc.) and with the same exact network and hardware setups. The only difference is Roon is not used.

This is the only thing holding me back from subscribing (am on a trial now).

Hoping someone can help with this… is there some setting I have overlooked?

Roon uses quite a bit more bandwidth over the network when sending the files to the endpoints (your KEF in this case) than other apps. It is not recommended to use WiFi for anything other than controlling playback.

That being said, you might try only sending one WiFi band to the KEF (5gHz WiFi would be faster but more limited range). Or if you can hook up ethernet to the KEF, this is what I did with my LS50W and it fixed my playback issues. Although I ended up adding RPi with Ropieee so that I can group the zone with others (my version are only Roon testing and not Roon Ready).

See this KB for more info:

Tell that to my Fiio M11 Plus it’s faultless on Wi-Fi and plays DSD256 without dropping a beat. Wi-Fi can work very well if implemented well.

Thanks for this! It pushed me to do a manual reboot of my router this morning (the router is set to automatically reboot weekly and the issues persisted a number of these automatic reboots) and in the 15 mins I had to spare the playback issues with Roon were gone. I will do more testing when I am back tonight.

I didn’t think it was my network because all other devices connected to this router’s 5G wi-fi all works fine (4K h.264 Mp4 videos even stream ok over this router’s 5G wi-fi) and I had no issues playing 24B/192khz FLAC to the speakers via UPNP/ DLNA (using the KEF app) over wi-fi.

Unfortunately running a cat 6 cable to where the speakers are best placed is not possible in the short term, I just don’t have one long enough.

I get around 300-350mbs WiFi at my LS50W master unit - it’s about 4-5m, almost line of sight from the hub

Mine drops occasionally; if it does, normally in the first 10 mins or so (anecdotal, I haven’t really noted it) and then it settles down

On my main system, I went Cat6/7 all the way - it’s 10s of metres but I bought the flat stuff (1x6mm?) which is fairly easy to hide (mostly) or run on the edge of door frames etc

Bit of a PITA but well worth it

It’s very device dependant, in KEFs case they have had, for me, bad WiFi signal. It did get “better” with firmware update, but still spotty, even sitting right next to my main AP. The “fix?” was to hardwire them.

1 Like

Latest update and to close this off for now
I still do not know what caused those issues and why I only had issues with Roon. Issues came back after reboot of my router so I did a clean reinstall of my router’s firmware (wipe, reflash, and configured from scratch instead of restoring from backups), also moved Roon to my NAS instead (Synology DS920+, Roon installed on NVME SSD volume, library on the NAS HDDs), everything else kept the same (KEF LS60 speakers still connected to router via 5ghz WiFi, Roon core wired connection to the router). No issues since albeit it has only been a few days. Looks like something fixed itself in the process.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.