Unable to recognize .dff files

Hi Roon support team,

My Roon does not recognize my .dff files as audio files and therefore does not integrate them in the library. The files do not show-up on the unsupported file section.
I have updated the tags for these files through several tagging softwares (TagScanner, JRiver) even if I believe .dff files does not have tagging features but that doesn’t help.

Any help would be greatly appreciated.

Hey @Guy_Maurier,

There are several reasons why a track or album might not appear in Roon. We have some great documentation about Skipped Files and why some files might not appear in Roon. I definitely recommend checking those articles out, it will likely point you on the right path.

In general, a great first place to look is Settings > Library > Skipped Files. If the track is here there should be a reason listed for it’s inability to be imported. Can you share a screenshot of an example album exhibiting this behavior in it’s storage location? This may help shed some light on why it’s not appearing in Roon.

Can you also provide some information about where your media is stored?


Hi @dylan,

Following your reply I noticed that the files are actually recognized however they are grouped as unknown artist. How does Roon handle .dff files and order them in the library? Do the files need a specific filename structure as .dff files do not have internal tags?


If you convert your dff files to dsf then you can tag them normally and integrate them into roon.

There are commercial converters out there. Here is a free one but it is command line. I don’t know if there is a GUI version: