Unable to remote access via Roon ARC

Mac Mini late 2014 dual core Intel i5 8GB Ram
Google fiber 1 GB internet connection via Orbi mesh router 2018 model year. Mac Mini is ethernet connected via netgear switch from Orbi RBR50 main router.
Roon operates seamlessly through the home, including new app for local in home file download. UPnP is enabled at the Google Fiber modem. Exceptions written to enable Roon access to the Mac Mini.

Problem - I cannot access outside the home and receive this error message:

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“server_ip”:“”,“found_natpmp”:true},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

I have tried static IP, Port Forwarding without success so reverted to standard settings.
I am certainly not an expert with network configuration. Appreciate any advice the community can provide to enable Roon ARC access remotely.


Number of Tracks in Library - 23,205 tacks

Description of Issue

How many routers do you have between your core and the public Internet?

Two - Google fiber modem to Orbi RB50 (which has two satellites). Ethernet is connected to the RB50

OK, you’ll need to get rid of one of those as “a router” or set-up manual port forwarding:

Google → Orbi
Orbi → Core

Each router needs its own port forwarding rule. UPnP will not work with multiple routers.

OK - Thanks. I will need to set up a port forwarding rule for both. I will give it a go. Let me see if I can figure that out for the Google fiber box to Orbi.

Resolved - thanks for the advice.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.