Unable to restore backup after db failure

Roon Rock Version 1.0 (build 227) stable
Intel NUC i7 16GB
Roon Server Software Version 1.8 (build 790) stable

Unmanaged 24 port Linksys switch → ISP router.

AppleTV, iPhone, iPad, Dell Windows 10, Schitt DAC.

The Rock has been performing solidly since installation. I had backups to my ancient Thecus NAS without issue. I had read it was best practice to backup to a couple of different places, so I added another location using the attached WD USB drive, which is where music is stored, again without issue and performing like a champ.

Shortly after the add’l backup location was saved, Roon failed, stopping midstream. The client app simply reported “There was an issue loading your database”. Reboot of the NUC did not resolve. I can load the IP page which gives the OS, DB & Settings and Network details, but the client software on a typical Dell Windows 10 machine fails. As does the app on iPhone, iPad, and Apple TV.

I figured my next step is to reset the DB. Choosing this option gave error:
Settings and databses could not be reset. Please try again, or contact support. {“status”:“Failure”,“exitcode”:2}

So I tried again, same error.

Next I hit reset button on Roon Server Software option, no error, but did see the Missing Codecs warning. Progess! I restarted the Roon client which then connected as a new installation.

Logged in, navigated to settings, backup, located my backups, chose the previous day’s backup and began the restore. It hung at 27%.

What is my next step?

Hi @J_Ricardo_Saldana and welcome to the Roon forum. Sorry to hear you have issues. I’m not support, they’ll be along in time. I’m just another user but I’ll try to help while you’re waiting.

Database issues aren’t fun. The next thing I’d try is restoring from an older backup if you have one.

After the failed restore, I tried once more and pointed to an older backup, n -2. This time it worked without an issue. I do recall now that I moved the original backup folder to a different location after I created my 2nd backup folder. I think it was that move, and not shutting down ROCK, is what led to my issues. Lesson learned. Thank goodness for my multiple backup copies! All is now hunky dory and I am fully restored and backing up to 2 locations.
This thread can be closed out.
Thanks, killdozer!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.