Unable to run Roon after "1303" update

Roon Core Machine

Win 11 / i9-12900K / 32gb RAM

Networking Gear & Setup Details

Wired ethernet to FIOS router via ASUS 1G switch and CAT6e

Connected Audio Devices

Merging HAPI II via Ravenna/AES67
exaSound s88 via USB or ethernet

Number of Tracks in Library

95,000

Description of Issue

After download and install, the white screen with the logo appears but the logo is static and nothing happens. Reboot = same. Re-install = same. Delete, redownload and reinstall = same.

Hi @mitr

Just a Roon user here.

Are both your Roon core/server and Roon remote on 1303?

Hi, @mitr, could you, please, use the directions found here and send over a set of logs from your Roon Core (RoonServer) to our File Uploader?

Thanks!


Ivan

Yes. One box.

I have uploaded mitr.zip

Hi-

Any ideas on the problem and possible solution?

So, it has been a week since I uploaded my logs as requested. Has anyone looked at them?

Added info. Even though the app on screen is sitting there without seeming activity, it is eating up my system memory and churning my NAS (where the music files are).

Hi @mitr,

Thank you for your post and for your patience - our apologies for the delay.

The most recent Roon system logging available to us from your Roon Server machine indicates the following might be the most fruitful pathways for troubleshooting:

  1. The Exasound RoonAPI client appears to be encountering traffic filtering on your network - RAATServer forcibly closes on your network when RoonAPI disposes of that client.

We suspect a network firewall, antivirus software on the Windows device, or software competing for the same port assignment is responsible. I’d verify the following when you have a chance to test:

  • Verify that RAATServer.exe is added as an exception on your Windows firewall if you’ve recently taken any Windows updates.
  • Double-check the security settings in your FIOS router. When you exaSound is connected via Ethernet, is it on the same router as the Core, or is the switch in between? In any case, try a different ethernet port.
  • If you have any additional security software, VPNs, etc., please test with then temporarily disabled to reduce the variables at play.
  • As a last and more heavy-handed test, you can try temporarily removing the exaSound API client and respective Zones completely. Creating a Backup with retain any MUSE settings or other Zone customization.
  1. Roon is struggling to analyze your local library; even with lower-quality files, analysis times are much higher than expected. Are you able to provide us with the following?
  • A screenshot of the Clean Up Library dialog window from Settings → Library. We’re curious to see how many Deleted files Roon has identified, etc., from your Z: drive storage location.

  • Example media from this Z: drive for our team to analyze. Please provide at least one 2-channel track and one 8-channel track we can test. You can use our Media Uploader here at your convenience.

  • The IO failures with this storage location accompany network failures - basic upstream requests to fetch the time or call Roon’s servers are timing out. This corroborates the suspicion that a network firewall or security feature is filtering traffic between your Core and your router.

The more details about your network setup and where you have your hardware connected, the better.

We’ll proceed from there. Thank you again for your patience and we look forward to your response.

OK. Here is an update.

It turns out that, in fact, the new Roon version is loaded and running but that there is no GUI to access it on the host PC! I can access it via a Roon Remote on my iPad to confirm that.

I have tried multiple times to download and reload Roon Desktop Application but I never get a GUI.

What is the solution for this, please?

AJ

Hi @mitr,

I’ve merged your two topic threads so we can keep track of this issue in one place.

In addition to the steps I’ve provided above, let’s refresh your RoonServer and GUI install completely by performing the following steps:

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder.
  • Verify if the issue persists, then restore the backup

The new simplified build will install the Remote function on Windows automatically in addition to the background server process. Although the processes (server + GUI) are now split, this download will install both on your Windows machine.

Happy to answer any questions.

FWIW. None of the above worked. Same when I tried 1310.

Just now, I have installed 1321 and it runs fine with no changes from my last trials with 1310.

@mitr, I will close this request as B1321 appears to have resolved your issue. I also am tagging @connor in case he wants to contact you about what you experienced with B1303 and B1310.

Never mind!

Installed and ran once. Will not reload. Bah.

Kal, I have asked @connor and @support for assistance for you with B1321.

1 Like

Hi @mitr,

Thank you for your patience over the weekend. We’ve taken a closer look through the most recent diagnostics available to our servers from your account and we believe you might be encountering a known UI issue affecting Windows installs of Roon.

Would you please try the following on your Windows 11 machine and let us know if it resolves the issue?

  1. Close Roon

  2. Navigate to: C:\Users(username)\AppData\Local\Roon\Database\Registry\Client\

Note: It may require enabling “show hidden files and folders” to see this.

There you should see the file: saved_window_pos.

  1. Rename this file to saved_window_pos.old, restart your computer, and launch Roon. Please let us know if it continues to crash or hang.

This should bypass the known mechanism for an unmanaged crash affecting the Remote component. We’ll stand by for your response and are here to assist. Thank you again for your patience.

Thanks for the suggestion. I tried this 4 times, each time renaming the saved_window_pos file and, each time, Roon hangs at opening. However, RoonServer is functioning and I can access it from a RoonRemote on my iPad. Unfortunately, that’s not generally convenient for me.

Nah. Worked long enough to restore library but, after the required restart, it’s all dysfunctional and inaccessible. Nonetheless, Roon is supposedly running and RoonService is eating up Memory and Network capacity.

Roon Core Machine

Win11, i9-129000K, 32mb RAM

Networking Gear & Setup Details

FIOS Router, ASUS switch, all wired. No VPN.

Connected Audio Devices

QNAP NAS for library, exaSound s88 via USB or LAN, Merging Hapi II via Ravenna

Number of Tracks in Library

~90,000

Description of Issue

Roon Core and Control are on the same machine.

After trying to update to 2.0 v1303 which failed, I tried progressively many updates through 1324. Finally, went back to 1311.

With all of them, Roon loads but plays only once. With all, Roon is installed along with Roon Appliance (which is a hog) and RAAT but, typically, the load screen just sits and cannot be accessed or operated.

If I fiddle with deleting, reinstalling or making random changes, I can sometimes get the installed Roon to play but only once.

This has been going on for weeks and Roon is effectively useless.

Hey Kal, just a fellow user here stabbing in the dark, but have you ensured the firewall exceptions are in place?
Have you also tried to install Roon server to make it the core and then the full Roon application to use as remote?

Good luck, and as I said, I‘m just stabbing in the dark…