Unable to scan main QNAP volume

Can someone help me out here on the setup on the QNAP?

I have setup RoonServer on an ext SSD labelled and formatted RoonServer

I have loaded Roon Server onto the SSD as per the instructions via QNAP app center. I knoow the Server is on the external disc because I have checked via the QNAP. I have brand new Roon firmware… It is a QNAP 470 pro with 4RAM

I have put in the music share paths which have been accepted as true “valid” paths by Roon OSX but I am getting the message “the drive containing this media is not available or the folder has been deleted” and the library is consequently not being loaded

All these shares are available with other services like SMB and DLNA servers (I use Asset and Minimserver and can be streamed to other players like my Heos, Kodi, Linn and direct via DLNA etc etc…

the path I am using is /Music/Stereo and my music files are in two subfolders of the Stereo folder. One is labeled 1 DSD Stereo and the other is Stereo PCM Lossless

I have tried adding the individual paths /Music/Stereo/1 DSD Stereo etc but I get the same error message…

This reminds me of the early Sonos days of setting up file shares. A much easier way would be to Browse onto the relevant shares don’t you think?

What gives here?

Do all music folders have to be subfolders of a shared folder (on the main disc volume of the QNAP) labelled “RoonServer”?


Hi Alex,

Roon Server is running on your QNAP and your music files are stored on the same device. That means you need to add them in the storage settings as a local folder. All created shared folders are accessible with the subpath ‘/share’.
In your case it means you should try adding

/share/Music/Stereo/1 DSD Stereo

The RoonServer share is only used to store the Roon database.

Hi. Thanks for the prompt reply.

I just added /share/Music/Stereo/1 DSD Stereo

…exact same error message…

Could you post a screenshot of your storage settings tab and one from the about window (when you click ‘about’ in the upper right corner in the settings’)?

edited. sorry (privacy)

edited again :slight_smile:

Thanks Alex.
Could you try adding


as a watched folder (without the subfolders)?

Yep. that did it… files are being imported now… it’s a big library… I’ll report back if further problems. Cheers :slight_smile:

(Hey this is pretty cool BTW… the server on the same linux based NAS as the files… ) pretty darn cool…

1 Like

If you want to add a specific subfolder check the spelling again. The entry for the folders is case sensitive, so it needs to be entered exactly as the folder name.