Unable to set Boot Priority

(James Jackson) #1

Hello,

I am just trying to set up ROCK on a Intel 7i7 NUCDNHE and am having problems getting past the BIOS update.

I can flash the update ok but when i go to set Boot Prority in Legacy there is no drive detected. This is strange because my NUC has two SSDs on board. Is there a setting somewhere i need to change to let the SSDs be discoverable ?

I have followed the Bios Update to theletter and everything seems fine except when i go to set boot priority.

This is frustrating since i can’t wait to load ROCK up and migrate Roon across.

Any help ?

Thanks

(Noris) #3

Hello @James_Jackson,

Thanks for contacting support, I’d be happy to take a look over this issue with you. Just to confirm, you have used our ROCK setup guide listed here, correct? A few other questions:

  • Can you please let me know what the full layout of the drives are in your NUC?
  • Are those two SSD the only ones in the ROCK or do you have an HDD installed on the ROCK as well?
  • Are you using one NVME and one SSD drive?
  • Can you please provide the model number for your hard drives residing inside the NUC?

Please let me know when possible and we can continue from there.

Thanks,
Noris

(James Jackson) #4

Hi Noris,

I am following the ROCK set up guide.

I have one NVME and one SSD installed… There is no HDD.

I bought it pre configured and am waiting for the specifics of the drives but the NVME is 128 GB and the SSD 500GB (which was not what i asked for but what i got and i will be changing it to something larger later)

When i get the models of the drives i will let you know.

Thanks
James

(James Jackson) #5

Here are the models

SSDPEKKW128G8XT (Intel® SSD 760p Series 128GB, M.2 80mm)
CT500MX500SSD1 (Crucial MX500 500GB 2.5" SATA SSD - 3D)

Thanks

(James Jackson) #6

I have been in contact with the people i bought the NUC from.
This is the response

Hi,
In most cases NVMe drive with not work with Legacy mode,
we have no experience on ROCK OS,
We have already test the drives before the NUC ship out by installing windows 10,
So the problem could be OS compatibility issue.
Please contact the OS developer for further support

Thanks

(Danny Dulai) #7

if you boot w/ just the nvme ssd in there + usb stick, does it let you install on to the nvme? if you remove the usb, does it boot from the nvme?

(James Jackson) #8

Hi Danny,

I haven’t even tried to install ROCK yet since i couldn’t get past the BIOS setting requirements .

Unless i is understand you, you want me to try to install ROCK after removing the second SSD.

Point is i can’t change boot priority in Bios (Legacy) since when i choose Legacy Boot no drives appear to nominate.

I have taken screen shots of Sata and PCI settings and sent them to the people i bought the NUC from (at their request)
Hopefully they will see something there to change which will allow the drives to appear in Legacy Boot options.

If i can set boot options it should be a breeze from then on.

Would you like to see the photos to see if you see anything obvious ?

Regards
James

(James Jackson) #9

The Vendor got back to me saying everything is ok…

They are advising me to ignore the Bios Boot Priority in Legacy settings and just go ahead and install ROCK anyway after having updated the BIOS (which i have done)

Will that work ? Or will Rock simply not work if i don’t follow the guides instructions to the letter.

I am beginning to think this has been a waste of time and money. Frustrating to say the least as i reckon this should have taken about half an hour to get going.

Do you have any solutions ?

(Danny Dulai) #10

You need to try, we don’t have your SSD.

This is the DIY nature of ROCK.

(Ricardo del Pino) #11

It works. I had a similar issue, and eventually worked. After the installation from the USB, the SSD appears in the Boot priorities in Legacy settings.