Unable to start the Roon Server on QNAP


I face some problems using ROON on my Qnap NAS as a server.
A long time ago it is working perfectly, but I try to start it a week ago, it has problems detecting any audio device. No matter my Cambridge CXA-81 or my ASUS Essence STX II Sound card on my PC. So I study the post in this forum and suspect it may cause by the QNAP securities problem.

Then I decide to uninstall the ROON Server and download the 1.8 (build 814) stable again, but it doesn’t work. keep the stats in STOPPED mode.

I hope to download the Logfile Zip to clarify where is the problem, but it does not work either.

May I have some advice to make it work again?

Still have the required share; “RoonServer”? And the application running in a context with write access to this folder?

Thanks for your reply, but this should not be an issue on QNAP, as the “RoonServer” shared folder is not mandatory anymore and the database storage location can be selected in the Roon Server web ui.
Permissions issues are also only relevant on Synology DSM7 installs.

Can you try uninstalling Roon Server again and try to perform an offline install?
This is done by downloading the RoonServer from the Roonlabs website manually (you can use this link to directly download the file) and put it in the Public shared folder of your QNAP. It is important not to rename the downloaded file. It has to be RoonServer_linuxx64.tar.bz2.
Then perform the installation from the App Center again.
Now the installer will not try to download this file during installation and pick the one from your Public shared folder instead.

1 Like

Failed to install the bz2 files due to format error.

I try to download the file, and then upload it to the public share folder, and then use the manual install function within the AppCenter, then it shows the error message. I check in the log, it said failed to install due to format error.

Sorry, I think there was a misunderstanding in the procedure.
The file RoonServer_linuxx64.tar.bz was not meant for manual installation.
Just copy this file in your Public shared folder of your QNAP and install Roon Server as you did before in the App Center (no manual Install here!).
The current official installer will check the Public directory for the file RoonServer_linuxx64.tar.bz before it will download it from the Roonlabs website.

The file RoonServer_linuxx64.tar.bz in your Public shared folder will be deleted automatically after Roon Server has been installed.

Thx Cristopher.

Finally, I have installed the Server File again, but it is still Stopped. Not sure where the problems are.

Thanks for sharing the screenshots. They really helped here and sorry for the trouble.
I can see now, that the issue is caused by the step of setting the database location, (the web ui, does not show any info about it).

I just checked this with a clean install on my qnap again and had no issues. Could you let me know, if you access your QNAP Administration by its IP address or by local domainname or even remotely by myQNAPcloud?
If you have not already done it, can you try to login to your QNAP by IP address and click the Change database location button and select your storage folder for the Roon database again?

Thx Christopher,
Finally, I make it, by connecting the QNAP with IP address.

1 Like

I have a similar problem. After the client upgraded to the latest OS, it stopped seeing the Core. I have tried downloading the QNAP app again but it only downloads the 2021-05-18 version. Is this a problem? I tyried downloading directly from QNAP and this is the only version available. Any ideas?

SOLVED. I updated the QNAP to version 5 and then had the option to download the latest version. I can now start the core but I still cant connect to it. Ipad just has an animated Roon logo showing.

You will need this one.
Install manually, according to instructions.

Just done that. Exactly the same. It see the core but then all I see is the animated roon icon. It does not want to work. It is on Linux 5.10.60 version 1.8, build 850

Just deleted Roon and reinstalled again and still no change.