Unable to update from version 1.7

Core Machine

Intel NUC 7 Mainstream Kit (NUC7i7BNH) - Core i7, Tall;
Transcend 256GB Nvme PCIe Gen3 X4 MTE110S M.2 SSD Solid State Drive;
Crucial 8GB Single DDR4 2400 MT/S (PC4-19200) SR x8 SODIMM 260-Pin Memory - CT8G4SFS824A;
Files are stored on a stand alone hard drive attached to NUC 7 with USB cord

Network Details

Xfinity xFi Gateway modem/router

Audio Devices

Oppo 203 HDMI
Muzo USB

Library Size

.7 Gigibytes

Description of Issue

Every time I open the room app on my phone or tablet (both apple) I am told I need to update from version 1.7, but before the latest version can download, the app closes. This happens every time I try to use Roon.

Hello @Streamingamigo,

Thanks for letting us know of the issue you ran into.

I was wondering, the trouble in updating, is it for your remotes, or your Roon Core? We recommend updating the Core first and only then your remote devices.

I’ll keep my eyes open for your reply :nerd_face:

I have tried to update with the remotes. I am not sure how I would update the core without accessing it through the remotes (Apple phone and ipad)

Thanks, Ed

Hi Ed,

Are you running Roon ROCK on your NUC Core? If so, you can update the software by accessing the Web UI.

From the Web UI you can select Reinstall the Operating System to update the Roon Server software.

Hope that helps.

Cheers, Greg

1 Like

suggest you update to the latest iOS Roon Apps on the Apple App Store

I found no update in the Apple App Store. Tried deleting the app, and reinstalling, but after opening the app, I am taken same page where I am prompted to connect, but when I do, I get the same message: “There was an error checking for an update. Retry.”

But retry just gives me the same message.

Thanks, Ed

The Roon app will not let me access the Settings page until I update software, which I cannot do.

Thanks, Ed

Do you run Roon on the Win10 NUC? If so, you should be able to access Roon through the windows app and do the update. I use a NUC Win10 connected to my TV and a wireless keyboard.

1 Like

To further update my issue of being unable to download and install latest software (and therefore unable to use Roon at all), I have attached a monitor to the Intel NUC 7 and then tried to update software with the Roon App on an Ipad. I received the following message on my monitor:

The system is going down NOW!
Sent SIGTERM to all processes
nDNSResponder: nDNSResponder (Engineering Build) (Sep 21 2018 14:28:52) stopping
Sent SIGKILL to all processes
Requesting system reboot
[ 22.927239] reboot: Restarting system

Does anyone out there in the community know what I should do to fix this problem?

Thanks, Ed

Hi @Streamingamigo, have you tried running any tests on the RAM or SSD? any failures found on any of the hardware?

Thanks, I will give that a shot. I am also considering downloading the latest (1.8 version) of Roon software onto a fresh flash drive and loading that into the NUC 7. Any concerns with that approach?


Do you have any backups of your Roon database?

I have the original flash drive, with the 1.7 software version.

Hi @Streamingamigo, no concerns with that approach. If you don’t have backups you’ll be unable to recover Roon play history / playlists / edits, but if you have backups you can restore them after reinstalling and you’ll be good to go.

Thanks dylan. I downloaded ROCK to a fresh flashdrive, and, lo and behold, it is still Version 1.7. Apparently the only way to get the l.8 version on a ROCK system is to upgrade from 1.7, and my NUC 7 shuts down every time I try. The mystery continues.

Thanks again, Ed

Did any errors show up when you tested the RAM and SSD?

Can you please use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service)? Thanks!

I am still looking for a program that will test both RAM and SSD. Is there one you would recommend?

Thanks, Ed

You have Transcend SSD, so try their SSD Scope
It supports your MTE110S, but requires Windows :frowning:
Here is the list of some diagnostic tools for NUC.
AIDA64 is a great tool and has trial period.

1 Like

Hi @Serge_Tse — Were you able to run these tests?

Dylan, this is not my issue :grin:
Let’s ask @Streamingamigo