Unable to update Rock Roon Server

Roon Core Machine

Intel i7 NUC, *Gb RAM, 256Gb M2 SSD, 1Tb SSD library drive, running Roon Rock

Networking Gear & Setup Details

Full Cat 5 ethernet system, Draytek Vigor router as gateway, 9 Linn DS Sneaky Music players for different house zones.

Connected Audio Devices

Linn DS Sneaky Music players, remote from either Macbook or Android 11 phone

Number of Tracks in Library

6000 tracks on the disc at the moment

Description of Issue

I had been succesfully running Roon using my Linux PC as Core, decided to buy an intel i7 NUC from the list on the ROCK page, ( Serial #1C697AAE4B28), successful installation, codecs present, library formatted and filled, running version 1.0 OS, build 227, Roon server is 1.7, build 571.

When I try to connect from either remote, both of which are running 1.8, a core update is required, on every occasion the update fails. I have completed multiple installs successfully and checked the network access, HDMI output is nil whilst trying to update. It’s driving me crazy.

@support second user that has built a rock with the download image seemingly stuck at 1.7.

1 Like

Hi Chris,

Another user. You should be able to access the ROCK core via it’s web UI. This will let you re-install the OS which should download the latest version.

Clipped from Roon FAQ

Other ways of accessing the Web Interface:

The Web Interface can also be accessed by:

  1. Typing in the IP Address of the RoonOS Device in a Web Browser

  2. Typing the hostname, for example http://rock , http://nucleus , or http://nucleusplus

  3. Typing the .local suffix for the device, for example http://rock.local , http://nucleus.local , or http://nucleusplus.local

Hi Dan,

I’ve done this multiple times to no avail, despite an update completed successfully message my system remains at 1.7

Hello @Chris_Chapman2 ,

It doesn’t look like your ROCK is communicating with our diagnostic servers, or you didn’t get far enough to log in. Can you please send us a manual log set from your ROCK Core? You can use these instructions to access logs and then please upload them here and let us know, thanks!

https://workdrive.zohoexternal.com/collection/8i5239cc05950ac07456889838d9319545a82/external

Thanks Noris, apologies for the delay, we’ve been away, I’ve uploaded my log files as Chris_Chapman2 Logs.zip

Thanks Noris, apologies for the delay, we’ve been away, I’ve uploaded my log files as Chris_Chapman2 Logs.zip

Hi @Chris_Chapman2 ,

Thanks for sending over those logs! It looks like you are getting quite a few NameResolutionFailures when attempting to communicate with any of our Roon servers, please see the example below:

[appupdater] Couldn't connect to update server: System.Net.WebException: Error: NameResolutionFailure

If you have not tried doing a full restart of ROCK, I suggest trying that first. Please also ensure that the ROCK is getting a proper network configuration from your router.

If that still does not help, you can try to use static IP on the WebUI and manually put in a DNS (1.1.1.1 for Cloudflare or 8.8.8.8 for Google) and see if you are able to update that way.

Note: after updating it is suggested to switch back to DHCP so that if the IP address is used elsewhere there won’t be an IP conflict (or you can use IP Reservation in your router if you wish to remain on static IP).