Unable to update to 1.8

Core Machine (Operating system/System info/Roon build number)
iMac mid 2011, 3.4 Ghz, Intel core i7,12 Gig Mem 1TB SSD drive, OS High Sierra

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Hi speed internet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

Unable to install 1.8, After download it says "There was an error checking for an update ". I have had no issues running Roon on this iMac. Unfortunately my iPad Pro remote updated itself to 1.8 but cannot be used now until Core is updated.

i would appreciate some help on this . . .



Read all the comments. You might be better off staying with 1.7 for a while longer.

Thanks for your prompt reply, Kevin
I would be happy to do that if there was a way to go back to version 1.7 on my iPad again, as it will not communicate with 1.7 on core anymore . . .



Ah yes…forgot about that. Well…damn. Hope you get the installation issue resolved.

Tagging @support

I too am having the same problem. It appears that both my iPad and iPhone are updated to 1.8 but the iMac will not update with same error report as above.

I would also appreciate some help on this issue.

Thank you


Have you tried manually (re)installing Roon (from roonlabs.com/downloads)?

Lucky you [moderated]. I’d happily go back. It “looks nice” until you interact with it as a familiar user. And it’s not a question of getting used to changed, it’s about deleterious changes.
One of my suspicions is that Roon pandered to Tidal and not their paying users.

Yes, I have but no luck there, either . . . 1.7 core has always run very well for me but with that unexpected update to 1.8 to my iPad, which I can’t seem to undo, I am stuck between two worlds now . . .

That’s bizzar. So, you have downloaded and reinstalled Roon or Roon Server v1.8 manually? Did the installation fail? If so, what was the error message? After you installed v1.8, what happened next?

Hi @andre_gysin ,

How are your DNS servers configured?
Are you using Cloudflare DNS, Quad9 or Google DNS?

Can you try to download the latest version from our Downloads Page?

1 Like

I’m not using a DNS. I downloaded the latest available core software from Roon Downloads yesterday as David suggested but the “disk image” can’t really be opened. I don’t want to totally uninstall Roon core at this point, however, if it’s the only way. Also, my OS is High Sierra. Might that be an issue?

Thanks for your attention


As far as I’m aware, Roon works on macOS back to 10.10 at least, so 10.13 should be okay. What do you mean by “can’t really be opened”? Which image did you download?

Again, what is the error message that you are seeing? Can you share a screenshot? I just re-installed the desktop app for macOS. The process looked like this:

  1. Download the appropriate disk image and open it:
  2. Drag Roon into the Applications folder:
  3. Indicate that I want to replace the current installation:
  4. Launch Roon from Launchpad or Spotlight, confirming any warnings about it being an Internet download (not from the Apple App Store)

If you’re using Roon Server for Core, the process should be similar.


All’s well now, David, thanks to your specific instructions!
Having used Apple computers since 2003, I’m a little embarrassed to have neglected to drag the Roon logo to the app window just below!
Thanks for your time guys . . .


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.