Unable to use AppleTV Endpoint from Ubuntu 20.04 core

Roon Core Machine

Ubuntu 20.04 Core i5 32GB RAM

Networking Gear & Setup Details

TPLink switch all components ethernet connected

Connected Audio Devices

AppleTV ethernet

Number of Tracks in Library


Description of Issue

Unable to add AppleTV endpoint

Steps to reproduce:

  • remove existing endpoint because it stopped working
  • try to re-add it through Audio settings in Roon
  • AppleTV shows 4 digit password
  • Enter password in Roon
  • Roon adds endpoint, but it doesn’t work and displays a new 4 digit passcode

Tried restarting both roon core and AppleTV, repeated above steps, no change

1 Like

Reproduced on a different AppleTV (Both are model A1842) today. Tried on both tvOS 15.1 and 15.2, same behavior on both.

I’m not sure if this applies, but you may need to go into your ATV4k and change the port to 9330. I had to do that to get the ATV4K working as a display.

Thanks Jim - I think you’re talking about using the AppleTV as a display like this. My goal is to use it as an audio endpoint, not as a roon display. Appreciate the feedback, in any case!

1 Like

@Mark_Mitchell thanks for starting this thread. I have the exact same problem. AppleTV Model A1842 (32GB) gives me an AirPlay PIN whenever I try to transfer to it. I tried with tvOS 15.1, failed, upgraded to tvOS 15.2 and failed again.

Help Center Troubleshooting

I found a relevant Help Center article, FAQ: I’m having problems setting up AirPlay. This article is a year old, so it predates the September 2021 release of tvOS 15. I tried all three trouble shooting steps recommended in the article:

Update Your Firmware

I updated from tvOS 15.1 to tvOS 15.2. I continued to get PIN screens whenever I tried to play to the AppleTV.

Confirm Your Security Settings

The article instructs you to “go to Settings > AirPlay > Security > Require Device Verification and set verification to off.” In tvOS 15, this setting is not available. Similar settings are available in Settings > AirPlay and HomeKit > Allow Access. I opened this up as much as I could, and the problem persisted. I tried:

AirPlay: On
Allow Access: Everyone
Require Password: Off

Check Your Network

The AppleTV and Roon host are hardwired into my LAN. The Roon core sees the AppleTV right away. AirPlay works find with other devices, including HomePod Mini and Denon AVR-X4300H.

Thanks Peter for confirming this issue is not just me.

Hopefully somebody from @support will be able to follow up this week!

Hey @Mark_Mitchell,

Thanks a whole lot for letting us know of this. We’re sorry about the trouble.

I wonder, could you please disable the restrictions on your Apple TV and see if that helps?

Restrict access to content on Apple TV - Apple Support (Remove all restrictions section)

Hey @Mark_Mitchell, if the restrictions don’t help - on the Apple TV, if you go to Settings > AirPlay and click on Airplay Everyone, you will see Security below. This might show Require Code First Time Only but should be changed to a Password.

Thanks for the reply.

I took the following steps:

  • disabled the AppleTV endpoint in Roon
  • checked restrictions on AppleTV, found they were set to Off
  • changed the AirPlay mode to Everyone
  • restarted the AppleTV
  • restarted roon core service
  • enabled AppleTV endpoint in Roon
  • typed in 4-digit code on screen
  • selected the AppleTV endpoint in Roon
  • selected a track and clicked play
  • the password re-appeared on the screen, and the track did not play
1 Like

This is similar to my experience.

Hi @Mark_Mitchell ,

Can you please reproduce this part, note the time + date + track which failed and then upload a set of logs by using these instructions to our drive?


Please let us know once uploaded, thanks!

Reproduced issue @noris
Time: 9:50PM ET
Date: 26 Jan 2022
Track: Kyoto
Uploaded logs filename: Logs012622.zip

1 Like

Hello @Mark_Mitchell ,

We have tested this behavior on our end using Ubuntu and Apple TV and have not run into issues. Looking over your earlier post you mentioned this:

This does not sound like you enabled the password option, but rather are still using passcode.

Please give password a try and let us know if that helps!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.