"Unable to Use Arc" (ref#2PE2WO)

Network Setup

· I use my ISP's router alongside a personal router.

ARC Status

· ARC is *Not Ready*

Roon Error Code

· None of these are listed. It simply says "TIMEDOUT" or similar.

System or third-party *firewalls *or *antivirus software* can sometimes block RoonServer from reaching ARC.

·
Try adding RoonServer and its associated processes to the whitelist of any firewalls or antivirus software you have installed, including the Windows system firewall, if applicable.
[You can learn more about firewall exceptions with Roon here.](https://help.roonlabs.com/portal/en/kb/articles/firewall)

Has the status in Roon -> Settings -> ARC changed after adding exceptions in your firewalls and antivirus software for Roon?
ARC is still *Not Ready*

Don't give up yet.

· I'm stuck. I'd like to create a post to ask Roon Community for help.

Describe the issue

I'm unable to use arc

Describe your network setup

Tangerine / NBN

This could be the cause of your problems with Roon ARC.

If you look at the Roon Settings → Roon ARC page using the normal Roon application (Windows or Mac) or Roon Remote (Android or IOS), then as well as the “Not Ready” indication that you have indicated above you should see some diagnostic text. It would be helpful if you copied that diagnostic text to a reply to this thread.

However, if you see “MultipleNATFound” in the text, then it means that the presence of the second router is preventing Roon Server from setting up the uPnP port forwarding that is necessary to make ARC work when connecting from outside of your home network. In this case, you may find that an earlier reply of mine to someone else with a similar issue will be of help:

Sorry I mean I have a personal router connected to the NBN modem box connected to the wall, rather than 2 routers. I don’t think that that setup would cause the problems that you mention.

Can you post the diagnostic text from the Roon ARC settings page please.

Also if you could post the ip address of your Roon Server and the Lan side ip address of your router (both of which will likely start with 192.168.

Hi Wade,

thanks here’s the diagnostic text:

{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“116.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true,“error”:“Did not find UPnP service with WANIPConnection on network”}
}

The IP address of the Roon server is 192.168.1.12
Lan router address is 192.168.1.1

This error seems to indicate that the router at 192.168.1.1 does not have a direct connection to the outside.

Can you make a note of your router’s WAN side ip address (if everything is working well it will not start with “192.168”, “10.” or even “172.x” where x is in the range 16.31). Then compare that ip address with the ip v4 address you get when you go to whatismyipaddress.com. Do not report either address here unless the two addresses differ and the router’s WAN side ip address starts with one of the non-routable address ranges that I listed just above.

If they are the same then everything is good and you just need to sort out your port forwarding. Try disabling uPnP on your router and setting up a manual port forwarding rule to forward TCP connections on the port indicated on the Roon ARC settings page (often 55000 or 55002) to the same port at 192.168.1.12 (your Roon Server’s ip address).

Alternatively, if they differ, then there is another address translation happening between your router and the internet. This may be NAT on another router in your network or it could be CG-NAT used by your ISP (although, from what I can find, Tangerine in Australia do not appear to use CG-NAT - I pressume you are in Australia). The use of CG-NAT is often, but not always, indicated by an WAN side ip address of “100.x.” where x is in the range 64 to 127.