Uncertified device - Simaudio Moon Mind2

Hi guys,

Found it harder than necessary to find a solution, so want to share how I was able to resolve Roon seeing my Mind2 as an "Uncertified’ device. Hopefully someone else finding themselves in the same situation will benefit from this post. Am also hoping the PTB are listening so they can fix their broken processes.

Roon did not send me an email explaining that they were going to shut down my previously “Certified” device. So I unknowingly tried to reset the device today and was, of course, denied access. My perpetual license to Roon no longer worked. So much for having paid for perpetuity!

Researched the problem without finding a solution. Did eventually find the “developer” fix page which initially looked promising. Nope. That Web page let me enter my data, but would not finish the the process (Roon: get rid of that page; it’s dead).

Searched further. Nothing on Roon of use. Nothing on Simaudio.

Rebuilt the Roon server; 8 hours later that is still running and will at least run overnight. That also created a mess I have to clean up (six of EVERY album; really?), but it didn’t fix the “Uncertified” problem.

After determining the problem was created by Roon, but had to be resolved by the hardware manufacturer, I tried updating the Mind2 firmware using a wired connection as the Simaudio manual describes. Nope. Didn’t work. The Mind2 was still “Uncertified.”

Downloaded the Mind Controller software from Google Play to my Android tablet. Had used Moon’s Mind Controller crapware when I first got the Mind2. That’s what led me to switch to Roon (Mind Controller for Android was that atrocious), so I was reluctant to try it again.

But Mind Controller turned out to be the solution to updating the firmware for the Mind2. It took multiple attempts, but eventually the firmware versions (there are two) were updated and the Mind2 was recognized as a “Roon Ready” device.

I initially used my wireless network; using a wired Ethernet connection when updating the Mind2 might be a good idea.

Without any help I was able to sort out my problem. Good thing I’m a computer gear head techie kind of guy, huh?

All it cost me was an afternoon lost trying different approaches because Roon and Moon (the alliteration is SO appropriate) left me in the lurch. Based on what my company pays me, you two owe me ~$800.

I love both your products and luckily I am technically adept enough to find solutions on my on. But, in this instance, both of your company’s support, in my experience, fell short.

At the very least, keep your websites and instructions up to date and instructive. Get rid of non-functional web pages (like the developer sign up and instruction pages).

Let me know if you have any questions. I want both of your companies to thrive and be successful and am happy to provide additional feedback.

FWIW, Moon is getting a copy of this, too.

I find actually trying to directly contact the company for tech support usually helps. This sounds like more of an issue with Simaudio than anything. And even more so, a self-induced problem for not keeping your firmware updated. ¯_(ツ)_/¯

Sounds like Simaudio finally got their false advertising solved by getting their device Roon certified. All you needed to do was to update your firmware which should have probably been step one. I’m glad it’s working now.

A post in the Support Forum would have probably helped, but maybe not over the weekend.

Glad that works for you. Getting shut out of a product because of poor communication and bad processes is inexcusable.

I work for one of the top enterprise software companies in the world. None of our customers would accept your excuse. Neither will I.

But thanks for the input.

That was the fix. But I came to the original vendor first which is what most customers do. Repeated searches brought ZERO useful information.

Remember, Roon said they emailed everyone who would be affected. No. They. Didn’t.

I never received any advance warning.

But thanks for playing.

No offense, but you come off as pretty insufferable. If you’re so tech-savvy, shouldn’t updating the drivers/firmware been your first step? Thanks for your credentials though. I don’t think anyone cares.

The problem wasn’t firmware. It was company policy.

I am tech savvy. Trust me on that. But NONE of my Fortune 100 customers would accept getting shut out because of a disagreement over compatibility that came after the fact. If they bought a certified product, they would expect it to be certified to that level for as long as they owned it.

I’m no different.

I get what Roon is doing and it is a good thing. But they cost me half a day and more frustration than it was worth because of their poor communication. My post is not so fan bois like you have a chance to beat me up. My post is so that if someone else has the same problem they can more easily find a solution.

Enjoy the rest of your weekend.

We get it. You work for a big company.

I’m not a fanboy, I just would’ve gone with the most obvious solution and not spent half the day fussing around like you did. Sometimes tech goes sideways, that’s life.

Actually, the problem was some manufactures were violating Roon’s licensing agreement and advertising and selling their products as “Roon Ready” when they were not. Roon finally had to put their foot down and handled a bad situation as well as they could. Communications are never perfect and some customers might have been unaware. Again, a request for help in the Support forum might have saved you some time and effort.

1 Like

John, you’re barking up the wrong tree.

I’m trying to help the next guy that may have the same problem. You taking me to task for sharing my experience and providing feedback is ridiculous.

What are you trying to do? Be right? OK, you’re right.

Enjoy the rest of your weekend.

You can do that without blaming others for what is essentially your fault. Keep your tech updated. It’s not hard. Bisous.

Oh, I get that and your point is more than well taken. We’re on the same page.

I figured out the problem and posted it so others could find it. What’s the issue?

You basically ignored the “Is it powered on?” of tech support to spend a day putzing around because you didn’t want to be “spoon-fed” by tech support. Thanks for the sensible chuckle tonight. ; )

And you failed the computer cup holder test.

You’re missing the point. I didn’t need tech support. Which wasn’t available anyway.


I’ve closed the thread since the OP has made his point and further comments were getting out of hand.

If someone feels they have something further to add to the conversation that isn’t attacking other users, feel free to PM me or another Moderator and we can reopen the thread.