Unexpected error adding network share

I get the extraordinarily unhelpful error message “There was an unexpected error: Unexpected error” when trying to get my Nucleus to look at the AppleMac’s Music folder. I have tried following the advice on the Roon website which isn’t helpful as it does not explain properly how to do this when the shared folder is not on the same device as the Roon Core (i.e. it would be helpful if you explained that you also need to add in the name of the device, not just the folder path). For software that is supposed to be easy to install, this is anything but. One of my major gripes with Roon is the installation process is designed by experts for experts. Please provide a “how to” guide for people with ZERO knowledge of network topography or nomenclature. It is so exasperating…

This article looks to me like it assumes you are accessing a remote share on the Mac.

Thank you for finding that article - it still doesn’t explain how to go from knowing my computer’s local name to what I put into the first line. Do I add “smb://” in front of this or does that do something else? Do I then need to navigate to the right folder as per the article on “Adding folder by path” where I need to add my user name? This is what I mean by articles written by experts for experts…

It shows you what to put in the example
Just put in your computer and directory

Thanks but I don’t know what a directory means? I am trying to share the Podcasts repository on the iMac which is this:

/Users/christownsend/Library/Group Containers/243LU875E5.groups.com.apple.podcasts

but when I put this in after the smb://imac.local I get the same old message that there is an unexpected error. It would be much more helpful if Roon could explain what the error was rather than just leave it to the community to fill in the gaps.

Hi @Chris_Townsend,

I think the first step here is to make sure that we have the folder you’re trying to use properly shared. We have information about this here in our Help Center. Can you share screenshot of the share settings showing this folder shared? Once we see how things are shared we should be able to get things going from there. Thanks!

Thanks Dylan - this is what I have.

I also have a problem with a stuck network share when I was trying to do this earlier. How do I get rid of the top share? There is no little blue x to delete it.

Hi @Chris_Townsend,

If you try to specify a new network share in Roon and re-add the share, are you able to do so?
Is there any change in behavior if you try to reboot your Roon Core?

3 posts were split to a new topic: Unexpected Error adding NAS Network Share

This topic was automatically closed after 20 hours. New replies are no longer allowed.