Unexpected Error Communicating w Audio Device

Roon Core Machine

Nucleus

Networking Gear & Setup Details

Uncertain over Wi-Fi

Connected Audio Devices

iTunes library on QNAP NAS playing through Belcanto streamer and amps.

Number of Tracks in Library

25000 + Tidal and Qobuz

Description of Issue

Getting the subject message when attempting to play tracks in my library on the NAS.

As a first troubleshooting step I’d suggest rebooting everything: Nucleus, NAS, the audio device in question, and all your networking gear (router, switches, etc). In short, reboot everything. If that doesn’t help it would be worth adding a bit more detail to your original post as support will probably require more information, particularly in terms of your network.

Any help appreciated, please. My IT and audio guys are stumped.

My Nucleus is hard-wired to my NAS, where my music resides. Normally communication between the Nucleus and the NAS are flawless. Suddenly, the app shows that Roon is no longer communicating with my music folder on the NAS. Message reads: This drive is not available. Check the drive or edit this folder. In fact the NAS is accessible via other means, and when I attempt to browse for the music folder I get a message stating: Error loading folder NotAvailable. Any epiphanies would be great. Thanks.

I have no idea what the problem might be, but I’d try creating a new folder on the NAS and see if Roon will accept it. If it does, it points to a problem with the existing folder (a permissions problem, perhaps). If not, then it indicates a more general problem with communication between the Nucleus and NAS.

1 Like

Hey @michael_maharam,

Thanks for getting in touch when things stopped being flawless. We’re so sorry that we didn’t get a chance to reply to this thread until now.

@DaveN’s suggestion is brilliant. I wonder if setting up a new network share for your NAS helped? How can we help? :nerd_face:

Hey @michael_maharam,

I’m so sorry to hear (via the private message you wrote) that the issue continues. Could you please update and add any information necessary regarding your setup?

  • what are the audio devices that you are using with Roon?
  • how are they connected to your Nucleus?
  • how is the Nucleus connected to the internet?
  • when you see the error message: Unexpected Error: Communication with Audio Device, are you playing a specific artist? Or maybe music from a specific source (streaming or local)? Or a specific quality?

Thanks in advance :pray:

Beka…a further diagnostic observation/question: digital radio no issue, play from my iTunes library no issue, add Qobuz or Tidal (or both) to the equation and the problem seems to arise. If this was due to internet instability, digital radio would be an issue. Is there a way to isolate so that I can take my music library on the NAS out of the equation and then isolate both steaming services individually to identify the problem? Thanks.

And I think this message (which preceded the prior) did not post earlier:

Hi Beka…

Apologies for the delay in responding…trying to gather my memory of how this system was configured as it is a bit complex…both a freestanding high-end Nagra system and a zone BelCanto system both running off the same music library/NAS/Nucleus;

First, the Nucleus communicates to the internet via CAT5/6 to a fiber-optic connection. Importantly, live radio is never an issue…no dropout of any sort. It seems that the dropout or failure to communicate is via Tidal or Qobuz if I had to guess. Ultimately, when I search a piece of music not in my library but still searchable and then attempt to play it, I get the subject message.

The Nucleus is connected by USB to the DAC of the Nagra high-end system. It is also connected by CAT5/6 to the remote rack where the BelCanto and the NAS live…assuming it is communication with the NAS which serves the BelCanto Streamers.

Though iTunes lives on a MacBook Pro and I purchase my music on this laptop, my iTunes music library folder lives on the NAS, where I assume it serves the Nucleus, as well. Music purchases are communicated via WiFi network from the laptop to the NAS.

Does this help??

Thanks…

Michael

m maharam

Beka…any news?? Thanks.

Hey @michael_maharam,

Thank you so much for the additional details. To reply, I’ve re-read our entire communitcation and I ran into this:

Message reads: This drive is not available. Check the drive or edit this folder. In fact the NAS is accessible via other means, and when I attempt to browse for the music folder I get a message stating: Error loading folder NotAvailable.

One question, if I may. You said that the NAS is accessible by other means. Where are you browsing for the music folder and getting the “NotAvailable” message. In Roon, or outside of Roon?

Could you please share a screenshot of Settings → Storage in Roon?\

Are you able, just like @DaveN suggested, to add just a few tracks or an album to a new folder you create on the NAS?

Hi Beka…here’s a screenshot of my storage configuration. The NAS is also used for my Acronis backup, which backs up daily. To my knowledge, a NAS does not hibernate or have the potential for dropout that might cause momentary signal loss. As mentioned, the problem does not seem to occur with DAB, so I assume that my fiber line is steady. I need to ask my IT tech to set up the folder Dave suggests because I prefer not to mess with his setup. I will do so. Thank you.

Beka…I’ve been trying to understand this issue more clearly. It’t not easy. By example; I search Madonna on either the app or desktop interface. The search returns a result…many songs from various albums. I choose a song that is on an album in my library and hit the Play From Here command, and I get the Unexpected Error: Cannot Communicate message. I then scroll down to Albums in My Library and hit play, and the album plays…no issue. Help me! Is it possible to speak with someone on the phone who can run through various diagnostic angles with me. I have two lifetime memberships and two Nuclei and I’m doing my best to be a good client, but Roon is not holding up it’s end…this has been months of daily nuisance with no progress. Thank you.

Hi @michael_maharam ,

I’ve activated diagnostics for your Nucleus and it looks like you have quite a few grouped zones, and the issue here is that one of your zones only accepts 2 channel content:

04/22 15:38:39 Trace: [1-Main Ceiling + 2-Main Floor + 3-Stube + 4-Garage + 5-Laundry + 6-Workshop] [zoneplayer/raat] Combining SRC work (StreamFormat(channels=2, bitspersample=24, samplerate=88200, isdts=False, mqa_core=44100) -> StreamFormat(channels=2, bitspersample=24, samplerate=88200, isdts=False, mqa_core=44100)) for 6 devices
04/22 15:38:39 Warn: [zoneplayer] failed to start stream System.ArgumentException: only supports 2ch content
04/22 15:38:39 Warn: [zone G21] Track Stopped Due to Error

I’m not sure how you are combining these streams, perhaps through DSP, but it is not starting due to this issue. If you would like to narrow down which device is impacted, I suggest ungrouping the zones and play to them one at a time. Hope this helps!

Good morning Noris and THANK YOU. This is the first really helpful diagnostic input I’ve received and I appreciate it. We spent five years building a very complicated home, which included a perhaps too complicated audio system. As we are remote (Italian Alps) I turned to a competent tech in London to set up the system as there really is no qualified support nearby, and sorting this issue out has been nearly impossible. My tech is no longer with the shop where he once worked, so I’m on my own and my technical skills are limited so If I could ask your help with a bit of direction I’d be very appreciative. Apologies in advance for any excess of detail.

Attached is an image of my grouped audio zones with descriptions below.

“Main” is our primary living area.

1- Main Ceiling are three pairs of in-ceiling Revox speakers serving one large room. Each pair shares a BelCanto REF500S amplifier and they all share a BelCanto Streamer and DAC. I assume this DAC serves multiple zones.
2- Main Floor are a pair of Stenheim floor standing speakers on BelCanto REF500S mono-blocks with a dedicated BelCanto (Roon Ready) streamer.
3- Stube is a den, and this has a free-standing Nagra system with dedicated DAC. A 1st generation Nucleus lives with this system and is cabled to the NAS, where our music library is stored.
4-6- These are secondary areas dealt with as an afterthought with networked BlueOS powered RAAT speakers.

Generally I run all the zones other than 2-Main Floor, and as the house has an open plan, the same music runs throughout the house.

My local IT is smart and has checked the fiber line coming into the house and the NAS for any signal fluctuation and finds none. The NAS is set not to sleep.

Diagnostically, will simply unchecking the speakers in the group zone selection menu be sufficient? And if so can I assume that all the BlueOS speakers should be unchecked simultaneously as they would have the same impact on the result?

Please let me what additional information might be helpful, and thanks again.

Michael

Noris?? Any news here?

Hi Noris, do we as users also have the ability to view the logs from Nucleus and set the log level? This way we might be able to detect the problems faster.

Hi @michael_maharam ,

Thank you for your patience here, I have discussed your case with our hardware team to try to get to the bottom of this error.

Yes, if you uncheck and save the group after, then those specific speakers should be removed from the group. I would try this first, to try to pinpoint the device that is causing the group to behave in this way.

Once you are able to locate the device causing the issue, our hardware team theorizes that this issue may be due to MQA Core Decoder. Can you please try to disable MQA Core decoder for that zone and check if that helps? You can toggle MQA Core decoder under Roon Settings → Audio → Cogwheel → Device Setup → Advanced for the zone:

Yes, logs are freely visible to users, you can use these instructions to access them if you wish: