Unexpected error: invalidRemoteData [Resolved]

HI, I’m running roon os1.4 on Mac OS 10.13.2 using iMac 27inch late 2014.
My music is stored in both an external 1T USB hard drive and a 10T QNAP Nas.
I have approximately 40000 tracks
My problem started about 2 days ago.I couldn’t log in, and got this message every time.
“unexpected error: invalidRemoteData”
I didn’t change any of my settings, please help, thanks!


Hi @Will_Lin ---- Thank you for the post. I saw your PM and responded to it here but I am glad to continue troubleshooting with you in this thread.

A few things moving forward. From your report it sounds like you have not encountered this issue before recently (i.e “two days ago”) and I am curious why you had to login again as this should only need to be performed when first setting up the application or when starting out “fresh” (aka with a new Roon database).


Hi Eric, thanks for your reply. Like you said, I’ve never encountered this issue before until last Saturday. I was about to enjoy my music like any previous days, and I found that I need to log in, so I did try to log in, and I never did after that. I was wondering what happened? One thing did happen on my side a week ago, that my ethernet stopped working, so I switched to wifi since then, roon was working perfectly under wifi then. I tried to log in from the web, and also tried to reset my password, and got a message like this. Please advise, thanks!

Will Lin

Hi Eric,
I took my iMac to the living room and hooked it up with ethernet, I logged in and everything worked again. So it looks like I need to connect my iMac using ethernet. Problem solved, whee!


Hi @Will_Lin ----- Thank you for touching base with me and providing this update. I am please to hear things are now functioning as expected.

Happy listening!

This topic was automatically closed after 28 hours. New replies are no longer allowed.