UnexpectedError when attempting to connect Synology NAS to ROCK

Just add the music to your last example. It seems to require a sub directory as well as the IP on add.



Thanks for your reply!

I have tried adding «\Music» at the end but it does not work. It does seem like it is trying But after 25 seconds I get the «UnexpectedError» again.

Ah, only have the network share location ,leave everything else like username etc blank

I have tried that as well - no luck.

I can put whatever I want after the IP-address but I still get the «UnexpectedError» after 25 seconds.

From FAQ: I’m having trouble setting up Roon with my NAS:

Remove any special characters from the share’s password and try again

This seems to be the last remaining tip from the FAQ above.

ROCK should support SMB v2 (as a server):

AFAIK it also supports SMB v2 as client. No need for the obsolete SMB v1.

What if you take “WORKGROUP” out ?

Thanks for your reply!

I only have letters and numbers in my pw - no special characters.

Thanks for your reply!

I have tried with and without WORKGROUP but it does not work.

Isn’t the right Samba share “smb://”?

Thanks for your reply!

I have tried using SMB as well as IP address but no luck.

Strange… I also have my Synology NAS as music share for Roon and it works fine.
I have to check with my own configuration at home. Will take about 8 hours though, as I’m at work right now.

That would be great! This is driving me slightly mad :upside_down_face:

It have a feeling that is is some kind of problem in the first “handshake” between Roon and the NAS.

Can you tick the read/write box on the user permissions page in settings.

On my setup that is checked/ticked.

See if that makes a difference

It’s been a long time since I used a NAS for Roon, or for anything.

If I remember correctly, one could specify the NAS log on id/password, rather than the folder id/password.

Don’t know if that makes a difference for you.

Suggestion. Create a new user on your NAS. Call it Roon or whatever. !00% add the permissions and set a really simple pw/

Add the folder to network share and be really precise on the user and pw (case sensitive).

I just did this on a Synology NAS that I never use with Roon and it connects right away.

If I don’t add a user/PW then I get the error you have. So this does point to an error with user/pw/permissions.

Beyond that I am out of ideas to suggest

1 Like

Thank you for your suggestion!

I tried creating a new user yesterday following the trail from your reply reg permissions, but it did not work. I will try it again tonight with the additional permissions check/ticking as you suggested on post 21.

Have you also checked the permissions in the Shared folder itself?
You also have to check the read/write permission there.

Actually that is the only option I have left.

I have now tried adding a new user with 2 letter credentials and made sure all read/write boxes are ticked but it is still not working.

Folder permissions

User permissions

Group permissions

Hello @Morten_Hansen, can you please verify that you can access your NAS via your network from another computer via finder or file explorer? Have you rebooted everything since this issue started?