Ungroup albums that shouldn't be grouped together | Profound Mysteries by Röyksopp)

@metadata_support How can I ungroup albums that shouldn’t be grouped together. The three dots give me no option to ungroup or remove duplicates.

1 Like

I’ve moved this to #support:metadata - it’s a metadata issue that needs to be sorted by Roon Labs. These look like two separate releases to me that should not be considered as versions of the one album.

Did you group them manually or did it happen automatically?

For manually, I believe you can undo it in Settings > Library, but I’m not home right now to check.

If it was done by default and if this is wrong (though it looks like the same album?? - edit: I see now that the second one are remixes), then I guess it has to be corrected in the database of the metadata provider, AllMusic and/or Musicbrainz. You can do this on your own at the AllMusic or Musicbrainz website, or post the issue in #support:metadata where Roon staff will pick it up (be patient)

I’ve already moved it.

1 Like

I have noticed this as well. But I just concluded it was a confusing display. That is, the albums are not actually grouped. If you click “Group all” then you will get the option to ungroup from the 3 dots. You will also see one of them displayed as “primary”.

So technically isn’t this a bug?

Well, it looks like they’re not grouped, but it still shows as one and the same album. If they’re not grouped together both versions should be listed, I assume. “Discography” also shows only one of both albums:


The problem is that Roon makes it two different versions of the same album. Which is a bit strange, if you ask me.
I’m also unable to set one of them as “primary”.
edit: I can set one of them as “primary” if I group them together.

Gents, this metadata error exists at source - it is not as a result of anything that @Dennis_Mutsaers has done in his library.

Here’s the result of searching for this “album” in Qobuz via Roon:

Yes. There are many profound mysteries in roon.

But the workaround that works for me is to

  • Group the album & the remixes
  • Remove the album (not the remixes) from the group

Now both albums show separately.

I’ve tried that too, but that makes the remixes album the visible album in my collection.

Strange. After grouping and ungrouping I get them displaying separately:

I still can’t get Roon to show both albums. :cry:

Did you try “cleaning library” after removing the albums before starting over? Roon will remember previous metadata/identifications unless you do that. If you have followed my steps above and it still doesn’t work I am at a loss. Profound mysteries indeed.

@metadata_support I’ve tried that, but it doesn’t make a difference.

Could @metadata_support have a look?

I have both albums via Qobuz they are treated as two separate albums they are not grouped. It will offer up the oher album under versions tap which makes sense but it’s not grouped I can manually group them if I want.

I call them “grouped” because I only see one album and have to use the “versions” link to see the other. I don’t think these are different “versions” of the same album, but should be treated as different albums entirely.

1 Like

They are two separate albums I have two albums both shown, but they are related and it’s why it shows up under versions.but it’s not grouped it’s just another version of the album like a deluxe version would be. Makes perfect sense as it’s a remix album of Profound Mysteries. If it was treating it as the same version it would be grouped but it isn’t it’s just saying there is an alt version of this album available.

The only way to find/show it is to use filter. Don’t use search, you won’t be successful.


or Discography

And it is definitely not consistent. Other remix albums are not shown as a separate version of the “main” album.

1 Like

Search finds either for me nothing wrong with this.

The original album doesn’t show up in Discography mind only the remix album unless I toggle the library only icon on then it shows it but then hides the remix album. So something odd here as both are in my library. Both show up in my library as two different releases.

This is my whole point…

1 Like