Ungroup albums that shouldn't be grouped together

How can I ungroup albums that shouldn’t be grouped together. The three dots give me no option to ungroup or remove duplicates.

I’ve moved this to #support:metadata - it’s a metadata issue that needs to be sorted by Roon Labs. These look like two separate releases to me that should not be considered as versions of the one album.

Did you group them manually or did it happen automatically?

For manually, I believe you can undo it in Settings > Library, but I’m not home right now to check.

If it was done by default and if this is wrong (though it looks like the same album?? - edit: I see now that the second one are remixes), then I guess it has to be corrected in the database of the metadata provider, AllMusic and/or Musicbrainz. You can do this on your own at the AllMusic or Musicbrainz website, or post the issue in #support:metadata where Roon staff will pick it up (be patient)

I’ve already moved it.

1 Like

I have noticed this as well. But I just concluded it was a confusing display. That is, the albums are not actually grouped. If you click “Group all” then you will get the option to ungroup from the 3 dots. You will also see one of them displayed as “primary”.

So technically isn’t this a bug?

Well, it looks like they’re not grouped, but it still shows as one and the same album. If they’re not grouped together both versions should be listed, I assume. “Discography” also shows only one of both albums:


The problem is that Roon makes it two different versions of the same album. Which is a bit strange, if you ask me.
I’m also unable to set one of them as “primary”.
edit: I can set one of them as “primary” if I group them together.

Gents, this metadata error exists at source - it is not as a result of anything that @Dennis_Mutsaers has done in his library.

Here’s the result of searching for this “album” in Qobuz via Roon:

Yes. There are many profound mysteries in roon.

But the workaround that works for me is to

  • Group the album & the remixes
  • Remove the album (not the remixes) from the group

Now both albums show separately.

I’ve tried that too, but that makes the remixes album the visible album in my collection.

Strange. After grouping and ungrouping I get them displaying separately: