Uninstall roon server on linux - command not found

I was attempting to remove roon server from linux mint so I could run ROCK again on my NUC. I ran this command

sudo ./roonserver-installer-linuxx64.sh uninstall

but I get a command not found error. I am missing something obvious probably, any ideas?

Perhaps someone from @support can help?

I have managed to stop the server using - sudo systemctl stop roonserver but I have not managed to unistall yet.

Tahsu this post is not in the support thread.
Would you like it moved there, or no one from Support will see it

Are you sure the script you are trying to execute is present in the directory? Try run

ls -la

and see if roonserver-installer-linuxx64.sh is there…

Thanks - I have just tried this, and no, roonserver is not showing, and yet it is running. I see too instances when trying to log in.

Yes please. I was thinking this was a tinkering item, easily solved, but perhaps I need a bit more help. Thanks.

Ok moved, hopefully someone will respond

What is missing is the install script. Roonserver is running because it has been previously installed, and the install script was probably removed after the installation.

What you can do is download it again to be able to use its uninstall feature. Try

sudo wget http://download.roonlabs.com/builds/roonserver-installer-linuxx64.sh

Edit: I missed to add that after downloading the install script you must make it executable:

sudo chmod +x ./roonserver-installer-linuxx64.sh

Then you can run the uninstall procedure as tried before.


This worked! Thank you for your help @Andreas_Philipp1, much appreciated.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.