Unreachable Linux Roon Server [Resolved]

Hello there @support

First post in that community looking for help regarding an issue that start recently. My setup is as follows:

  • Roon Server v1.3 (build 269) stable on linuxx64 - an Ubuntu LTS 16.04.3 VM (Linux 4.4.0-97-generic #120-Ubuntu SMP Tue Sep 19 17:28:18 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux)
  • Music folders accessed via an NFS mount (read only, fstab options -> nfs ro,hard,intr 0 0 ) with around 60k tracks
  • Multiple clients running either on macOS Sierra, or Raspbian

The problem is that none of the clients - including the Remote mobile app - is able to connect to the server, even though it is running. I have tried to reboot the VM, as well as the roonserver.service a few times but it did not help. This situation did not occur with any of the previous releases on that specific setup.

Do you have any idea where to start to understand where the problem might be?


Hi @David_Schmalz — Thank you for the report and sharing your feedback wth us!

Moving forward, to help us better understand what could be going on with your client devices, may I very kindly ask you to please provide me with the following:

  • Please verify the make/model if the devices you are experiencing this issue with.

  • Please describe your network configuration/topology, as well as providing insight into any networking hardware you are currently implementing. I want to have a clear understanding of what the chain of communication “looks like” across your setup and how these affected devices are communicating with your network.

  • Based on your report it sounds like this behavior was not always present. Besides the update to most recent build release, have there been any other changes to your setup?


My devices are:

  • iOS phones running iOS 10 & 11
  • computers running macOS Sierra
  • RaspberryPI with HifiBerry Digi+ running Raspbian GNU/Linux 8 (jessie)

All my devices are in the same subnet (and VLAN), connected to a single Gigabit switch and Wi-Fi access point (bridged).

My Roon Server automatically installs security updates, as well as all my RaspberryPIs. Apart from that, I have added a few tracks recently, after which I forced a rescan of the library because those were not picked up. The Server mounts the music folders via NFS exposed by a FreeNAS server

/etc/fstab -> freenas:/mnt/myzfspool/Music /mnt/music nfs ro,hard,intr 0 0

Thanks for touching base with me, @David_Schmalz! I appreciate you taking the time provide the requested feedback!

Moving forward, you mentioned that your Roon server automatically installs security updates and I am wondering if this is what could be causing the problem. If possible can you temporarily disable any active security related functions on your RoonServer/RasberryPls (i.e firewalls, etc) and confirm if this action triggers a change in behavior here.


Hello Eric,

Thanks for your response. I have disabled the firewall - even though it should not have any impact

$ sudo ufw disable

When I list all open ports on my Roon Server:

$ sudo netstat -apn | grep LISTEN
tcp        0      0 *               LISTEN      1083/rpc.statd      
tcp        0      0  *               LISTEN      4522/RoonAppliance
tcp        0      0 *               LISTEN      -               
tcp        0      0*               LISTEN      4511/RoonServer 
tcp        0      0 *               LISTEN      4522/RoonAppliance
tcp        0      0*               LISTEN      4555/RAATServer 
tcp        0      0  *               LISTEN      4522/RoonAppliance
tcp        0      0  *               LISTEN      4522/RoonAppliance
tcp        0      0   *               LISTEN      1085/rpcbind    
tcp        0      0 *               LISTEN      4555/RAATServer 
tcp        0      0    *               LISTEN      1009/sshd       
tcp        0      0  *               LISTEN      1314/master     

Finally, if I try to connect from another machine - same LAN - to check whether ports are actually available:

$ telnet roon-server.localdomain 9100
Connected to roon-server.localdomain.
Escape character is '^]'.

Now, when it comes to security updates, I am running a stable version of Ubuntu. It is impossible to guarantee that none of the security patches on the server have impacted the operation of the Roon Server.

Looking in the Roon Server logs, if found the following, which might be of interest:

10/28 13:00:59 Info: [brokerserver] Client connected:
10/28 13:00:59 Trace: [SOOD] Adding User IP
10/28 13:01:00 Info: [stats] 1713mb Virtual, 957mb Physical, 628mb Managed, 0 Handles, 27 Threads
10/28 13:01:00 Trace: SENT NONFINAL DistributedBroker.ConnectResponse={ BrokerId=7a868d29-b4d9-4e4a-821e-36a1dc3bb6d7 BrokerName='roonserver' }
10/28 13:01:00 Trace: SENT NONFINAL DistributedBroker.UpdatesChangedResponse={ IsSupported=True WasJustUpdated=False Status='UpToDate' HasChangeLog=False CurrentVersion={ MachineValue=100300269 DisplayValue='1.3 (build 269) stable' Branch='stable' } }
10/28 13:01:00 Trace: [push] restarting connection (Unable to read data from the transport connection: interrupted.)
10/28 13:01:00 Trace: [push] retrying connection in 90622ms

Hope this helps!

I continued my investigations and removed the last 3 albums I had added recently. I then stopped the scan of the associated storage location that seemed to be running in loops, re-added each album individually and forced a rescan.

Now the server starts properly again and my devices can connect. It must be related to a special event that occurred during the initial import and made the server go into a loop.

Let me know if you would like that I collect logs.


Hi @David_Schmalz ----- Thank you for the follow up and providing the requested feedback! The insight is very appreciated!

I wanted to touch base and see how things have been holding up since your most recent update (i.e removing the last 3 albums imported).


Thank you Eric.

Everything is back to normal after I performed the above. Note that I reimported exactly the same files, placed in the same location.


This topic was automatically closed after 26 hours. New replies are no longer allowed.