Unreliable streaming when using Android phone as the output zone

Hello @support

Few months ago I jumped in the bandwagon and bought a lifetime Roon licence.

My setup:

-SimAudio Moon 280D DAC with Mind 2 module (Roon ready)
-Music library is located on a Windows 2016 Server running the latest 1.6 roon core.
-my library contains mostly 16 bits/44khz FLAC files.
-Mobile device: Samsung S8, running latest version of roon

the problem:

I can stream with Roon very perfectly to my hifi system through my DAC. However, when I move into an another room or outdoor on the patio, I will transfer my current playing music to the Zone of my “mobile phone” and connect the phone to a Bluetooth speaker.

Invariably, when streaming to my phone the music will stop playing after some time (usually within 5 to 8 minutes). I need to go into the “now playing” screen and tap the “play” button again to get it going … until it stops again in a few minutes. It will always do that, I can reliably reproduce the issue.

I thought it might be bandwidth or wifi reliability related but I can easily reproduce the issue when sitting next to my wifi router.

I tried the same thing with my iPad instead of using my Samsung S8 and I can get reliable streaming on the iPad.

Looks like something is going wrong with the Android application.

thanks for the help.

Just to add, I connected my phone to my wired Ethernet network with a USB-C ethernet adapter. I also turned off wifi on the phone to make sure it was using the wired connection. Just want to rule out the wifi reliability out of the equation.

I was able to repro the issue when connected via wired ethernet network.

Hello @Marc_Genois,

Can you please let me know what your router model/manufacturer is? Does playing back directly to the Android phone’s internal speaker (instead of bluetooth speaker) work as expected ?

Also, how is your Core connected to the network, is it via WiFi or Ethernet and are you making use of any range extenders or powerline adapters?



Router is a Linksys WRT1900ACS. Latest firmware. However, like mentioned above, the issue is reproduced when the phone is connected through ethernet too.

The issue reproduce as well when using the phone speaker (not connected to a Bluetooth device).

My core is connected to my Ethernet network.

I am not using any extenders or powerline adapters.

Thanks for letting me know that info @Marc_Genois,

I have sometimes seen IGMP Proxying/Snooping affect playback in similar cases, can you let me know if you have this setting on your router and try to see if toggling it helps? If you have found it and tried it already then I kindly ask you to reproduce this issue once more and note the exact local time in your country (ex. 11:16PM) that you see it occur at and then I can enable diagnostics mode for your account and take a look for any errors.



I have checked the IGMP Snooping testing on my router. It was off. Turned it on and it didn’t change anything, the issue was still present so, I turned it off again.

I just reproduced the issue at 17h06 EST time


Hello @Marc_Genois,

Thanks for providing that timestamp, I am seeing a few NetworkError traces around the times you mentioned.

Hmm, I am not sure if you tried this yet, but does reinstalling the Roon app on your Android phone help at all? If not then I would take a look to see if you by any chance have “multicast filtering” turned on in your Router settings, if you do please turn that feature off.


Hey @Marc_Genois – have you checked the Android phone’s Battery Optimization settings? I’m not sure about your phone specifically, but you may be able to disable battery optimization for Roon in your phone’s settings.

We’ve found that some versions of Android can try to save battery by closing Roon in the background, which can manifest in symptoms like this:

Take a look and let us know if that helps ok?


1 Like

@mike Yes, I had already added roon to the battery optimization exception list and it doesnt help unfortunately.


Hi @Marc_Genois,

Thanks for confirming that for us. I’m going to bring this report to our technical team for additional feedback. So I have all of the information for the team, may I ask that you please confirm the following:

  • Please confirm whether or not reinstalling the Roon app yields any change.
  • When the pause occurs are you actively using another application on the device, or is the device idle?

Hello @dylan,

I tried to un-install and re-install the app. same behavior and issue.

When the pause occurs, I am not using another app on the device. I am just letting the device stream.


Thank you for giving that a try, @Marc_Genois.

I have updated your report and I have passed it along to our senior technical team for review. I’ll be sure to update you once I’ve received their feedback on this.